Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try and install Windows 7 service pack 1, I get an error that halts the install (code 80073701).

I've looked around quite a bit, and a lot of places say that a language pack may be the culprit, and suggested running lpksetup.exe and seeing if there were any (corrupted) installed language packs. I ran this and it appears my English language (default) pack is corrupt.

enter image description here

Is this most likely the issue, and if so, is there a way to go about reinstalling the language pack?

share|improve this question

2 Answers 2

I do not believe your language pack is corrupt. I setup a Windows 7 RTM machine (no SP1), and ran lpksetup. The window was the same as your screen shot. I cancelled out and was able to install SP1. I think lpksetup is just warning you that you only have one language pack, so maybe you don't want to remove it.

  1. Try the System Update Readiness Tool.
  2. Run System File Checker. Open a command prompt, and type sfc /scannow.
  3. Check C:\Windows\Logs\CBS\CBS.log for ERROR_SXS_ASSEMBLY_MISSING messages. That may lead you to an update that is missing something. Uninstall these updates, reboot, and try the Service Pack again.
share|improve this answer
    
It seems to reference the error code I gave where ever ERROR_SXS_ASSEMBLY_MISSING pops up: HRESULT = 0x80073701. The only place I see an update number referenced, it's the service pack 1 update itself (KB976932). –  Ryan Jul 18 '12 at 3:12
    
I posted additional things to try (#1 and #2). –  Patrick S. Jul 18 '12 at 13:34
    
I have unfortunately already run both of those without an issue. –  Ryan Jul 19 '12 at 3:23
    
Thank you for your suggestions! It is helpful advice, it just didn't fix my specific issue. :-/ I just went ahead and reformatted. –  Ryan Jul 20 '12 at 17:01
up vote 0 down vote accepted

After several days of searching for a solution (and not finding one), I decided saving all my stuff to an external hard drive and reformatting was the best way to go.

I reformatted and the first thing I did was install SP 1 (which worked).

If you have an external hard drive and either an installation disk or a recovery partition on your computer, I would suggest just reformatting. It will most likely take much less time than diagnosing the issue and determining how to fix it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.