Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On some files I am required to enter my credentials before deleting a file. It only happens on some file in my Pictures folder.

I while back I created another user and moved all the files from my old user. I ran the repair option from the boot menu and it did not seem to help. I am running Mountain Lion.

I checked the permissions on one file I needed permission to delete and this is what I found: enter image description here

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The ownership on the files is probably incorrect. The quickest way to correct the ownership issue is via Terminal.app. Since you've moved files from one user account to another, I'm assuming you have administrative rights.

In a Terminal, issue the following command to change the ownership of everything in your Pictures folder:

sudo chown -R /Users/<your_username>/Pictures

More Detailed Instructions

  1. Open Terminal: SPC and type Terminal. Hit (enter) when you see it highlighted.
  2. Type cd followed by a space on the command line you are presented with
  3. Open up a Finder window and drag the problematic folder to the Terminal window to insert the path. Hit
  4. Assure that you are in the appropriate directory by typing pwd. If your expecting to be in your Pictures folder, you should see /Users/<your_username>/Pictures
  5. type: sudo chown <your_username> ./* and hit enter. Replace with your short username (i.e. the name to the left of the $).
  6. Done.
share|improve this answer
    
How do I tell if this worked. It only took a few seconds and I have about 50,000 pictures. –  Paul Jul 19 '12 at 0:30
    
It's a fast operation. If ownership was the issue, you should be able to operate on all files now. –  ephsmith Jul 19 '12 at 0:52
    
@BoundforPNG The new picture you posted suggests that somehow custom Access Control Lists (ACLs) got set on some files. You may need to re-run ephsmith's instructions again, but for Step 5, do this: sudo chmod -RN ./*. This should remove all ACLs from all files in the directory sub-tree that you're in. –  Spiff Jul 19 '12 at 1:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.