Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's the situation, the first two entries to be exact (second one brushed):

enter image description here

This does not seem to be related to autofill suggestions in the search bar, which are set to be off in my case - these keep popping up. I can't remove them via delete/shift delete, as suggested in another topic.

That's not a problem, since I can click dismiss, but I'd rather disable their appearance once and for all; it seems like Chrome saves some of my YouTube (and potentially other website) searches and then suggests them to me. Saved forms are off to me as well, emails/passwords etc. don't get saved.

share|improve this question
add comment

1 Answer

I guess you are talking about Google Instant. If you don't need any suggestions from Google, you can turn it off through settings. Under Serach settings->Google Instant predictions-> click on Never Show instant results.

This will work out for sure.

share|improve this answer
    
My google instant search is not turned on in the first place. –  gchrome Jul 18 '12 at 6:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.