Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have openSUSE 12.1 x64 host and I'm running Ubuntu 10.04 x86 as guest.

My problem is that Ubuntu sees no network at all. I have both tried NAT and bridge setup but I have no interface on the VM. ifconfig returns only lo

VirtualBox version is 4.1.18_OSE running as a member of vboxusr group and I installed the correct addins in the guest.

How can I fix this?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

It appears that your guest only has a loopback interface for whatever reason.

Try entering the virtual machine settings and see if the VM has a network card installed.

If that is not the case. And you have recently changed the VM's mac address then I would look at this thread as the user seems to have the exact same problem as you.

https://forums.virtualbox.org/viewtopic.php?f=7&t=43090

specifically this "each time you give a new MAC address (in VBox guest settings) Debian and Ubuntu guests udev assigns a new eth number edit /etc/udev/rules.d/70-persistent-net.rules or delete the file: it will be recreated @ next boot"

share|improve this answer
    
I followed the advice and found that the .rules file has been recreated matching the virtual device's MAC address but still ifup eth0 says "ignoring unknown interface eth0" –  djechelon Jul 18 '12 at 8:33
    
I had to add "auto eth0 iface eth0 inet dhcp" to /etc/network/interfaces. Problem solved –  djechelon Jul 18 '12 at 8:35
    
Good, did you change the rules file by the way? or did you just notice it was correct? –  VBwhatnow Jul 18 '12 at 8:40
    
It was recreated correctly with the proper mac address –  djechelon Jul 18 '12 at 8:58
    
Worked for me also in Ubuntu 12.04 deleting that file: rm /etc/udev/rules.d/70-persistent-net.rules and then creating a wired conetion linked to the new mac in system settings/network/options –  DavidRSouto Aug 1 '13 at 18:53

Add a Bridged Connection to your N/W interface by using Network Options. If you have changed your MAC, then just deleting /etc/udev/rules.d/70-persistent-net.rules is not enough. Ubuntu keeps previous MAC entries as well in this file. While OS load, it cannot find previous MACs (since you have changed it to new) and hence fails at that point, failing to add new MACs and new interfaces. You need to edit the file. Follow the steps:

  1. Go to directory /etc/udev/rules.d/
  2. Do Sudo vi 70-persistent-net.rules`
  3. Comment the OLD MAC entries (e.g. # SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="08:00:27:XX:XX:XX", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1")
  4. Sometimes you need to make sure, for the new MACs, the interface names are in correct sequence, i.e. NAME="eth0", "eth1" and so on.

Originally posted by me in the virtualbox.org forum.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.