Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a shared drive I: in Windows 7, I want to access that drive from my Mac, but I am not able to connect to my windows. From Finder > Go > Connect to server

smb://192.168.0.101

It asks me for a Name and Password, I am entering name/passowrd that I used for my Windows account, but nothing happens after I click connect.

I can access internet on both my Windows 7 PC and Mac. I can ping from PC to mac and mac to PC What settings I need to get to that folder in Windows 7?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

I think this link would fix the problem?

http://answers.oreilly.com/topic/556-windows-7-file-sharing-with-mac-os-x/

These links might also help: http://www.trickyways.com/2010/06/how-to-access-mac-files-from-windows-7/ http://www.trickyways.com/2011/08/access-pc-windows-7-files-from-mac-os-x-lion/

share|improve this answer
3  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Sathya Jul 18 '12 at 12:26
1  
He already performed those steps. And second link makes no sense since he wants windows folder in mac not vice versa. –  Sandro Dzneladze Jul 18 '12 at 12:50

Did you try to put WORKGROUP\username in the username field ?

It will be helpful if you can see samba logs on windows machine.

share|improve this answer

One thing to look into is the security level Windows 7 is using. On the Windows 7 machine:

  1. Go to Administrative Tools.
  2. Go to Local Security Policy.
  3. Double click Local Policies.
  4. Double click Security Options.
  5. Find Network security: LAN Manager authentication level.

By default Windows 7 is set to Send NTLMv2 response only. This is Microsoft attempting to make Windows 7 more secure; however, it has the added effect of blocking requests from older operating systems that do not understand NTLMv2. I had a similar problem mapping a drive in Windows 7 to a file share on an AS400. I would receive the pop-up for my user name and password. Enter both correctly, then be prompted for credentials again. It would never go through.

Change the policy to Send LM & NTLM - use NTLMv2 session security if negotiated. It will use NTLMv2 if it can but use a less secure authentication level if needed.

share|improve this answer

You have to set user rights for sharepath not only in Network and Sharing Settings but in properties of the folder in security settings. I added guest as I've tried doing in the advanced sharing menu and Voila! I can now connect to share as guest without any problems from OS X. (Also, if you want to use Share Read / Writable, just set Full Access for the guest account.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.