Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently I have Fedora 17 installed on my system. For some Windows specific tasks I need to use Windows, so I want to install Windows 7 on my system.

All of the partitions on my harddrive are currently ext4. Whenever I try to install Windows 7, I can't use any of the ext4 partitions. I have tried to use the available free space, and I have also created an NTFS partition using GParted, but when I try to install Windows 7 on those partitions it says 'Disk not supported.'

I have also tried to create a GParted bootable image to create ab NTFS partition, but this didn't help as I still got the 'Disk not supported' error.

I have considered using VirtualBox, but it consumes a lot of RAM and my system gets slow because of it. I do not want to use VirtualBox because of this reason.

I need to solve this problem as soon as possible. Thank you for reading.

share|improve this question
    
I have tried deleting and formatting some partitions and free space but that also didn't work. –  Nitin Jul 18 '12 at 15:39
    
Do you use a MBR or GPT partition table? –  Marco Jul 18 '12 at 16:45
    
@Marco MBR partition table. –  Nitin Jul 18 '12 at 16:50
    
Try making the NTFS partition active. In GParted, you do this by setting the "boot" flag. –  Harry Johnston Jul 19 '12 at 4:35

1 Answer 1

I had a similar issue with win7 and linux a while back.

Keep in mind that there can be only 4 primary partitions and that win7 uses 3-4 partitions of which 1 or 2 primary.

I would advise to backup all your fedora17 data, install win7 on the whole disk and reinstall fedora afterwards. You have already wiped your fedora install, so you are already half way there.

I also recall win7 installing only at the beginning of the disk, but I cannot confirm this.

share|improve this answer
    
Windows 7 by default uses only 2 partitions, and can be installed on a single partition, which doesn't need to be at the beginning of the disk. It is true that it has to be a primary partition, though, which might well have been the OPs problem. –  Harry Johnston Jul 28 '12 at 23:51
    
It has been a long while since I had that issue. At that time, the copy of win7 I was installing, attempted to create a recovery partition as 3rd partiton, which broke my install and overwrote one of my linux partitions. Things could be different right now. –  Bruno9779 Jul 29 '12 at 16:47
    
That sounds as if it might have been OEM reinstallation media rather than standard Windows install media. Of course, the OP might be in the same situation. (I hadn't thought of that!) –  Harry Johnston Jul 29 '12 at 20:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.