Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I installed windows 7 a few months ago while my SATAs in my bios were configured as IDE. When I change it to AHCI for an added speed boost, I get a BSOD on startup. Is there a way or tool I can use to get my OS to boot in ahci mode without reinstalling windows?

I tried the windows recovery and start up fixes but they did not work.

Thanks

share|improve this question

marked as duplicate by Oliver Salzburg Oct 15 '13 at 21:29

This question was marked as an exact duplicate of an existing question.

up vote 0 down vote accepted

Yes, the tool is regedit.

You need to enable the AHCI part. Then shut down, turn AHCI on in the BIOS and boot into your faster system.

I had a post somewhere on StackExchange describing how to do that. I will look it up and link to it. Meanwhile try HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services. Look for msahci and change the value to 0.

Edit1:

Someone else answered the same thing but even added screenshots. That post is here on superuser question 110927

Edit2: My old post http://superuser.com/questions/432022/ahci-mode-gave-me-two-boot-options.

Start Regedit
Open HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlset / Services
Open msahci
In the right field left click on "start" and go to Modify
In the value Data field enter "0" and click "ok"
exit "Regedit"
Reboot and enable AHCI in the BIOS
share|improve this answer
    
A more detail list of instructions might be helpful. – Ramhound Jul 18 '12 at 15:52
    
Added a link to my old post and cut and pasted the instructions from the old post. – Hennes Jul 18 '12 at 15:57

Not the answer you're looking for? Browse other questions tagged .