Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install a perl plugin to pidgin, by placing the .pl file in the ~/.purple/plugins directory, as described here.

The problem is that when I put the .pl file in the directory and open the plugins dialog in Pidgin, my plugin does not appear. Does anyone know why this might be happening?

There is nothing in Help→About regarding Perl support, so I don't know whether it is enabled or not.

I am running Arch Linux and Pidgin 2.10.4.

EDIT As grawity pointed out below, I was looking in the wrong place for whether Perl was enabled. It is listed as enabled.

share|improve this question
    
Have you restarted Pidgin after putting the file in the plugins directory? –  ND Geek Jul 18 '12 at 16:09
    
Side note: Your Pidgin is a few months out of date, and the rest of your system is likely to be, too. –  grawity Jul 18 '12 at 16:59
    
Perl support information is in Help → Build Information, by the way. –  grawity Jul 18 '12 at 16:59
    
@NDGeek Yes, I have restarted Pidgin –  ewok Jul 18 '12 at 17:16
    
@grawity Thanks. How do I update? I have run pacman -S pidgin and it claims that I am up to date. I'm pretty new to Arch. Much more familiar with Ubuntu and Fedora. –  ewok Jul 18 '12 at 17:17

1 Answer 1

up vote 2 down vote accepted

The problem turned out to have been caused by an out-of-date system.

It's recommended to update Arch Linux at least once a week, and upgrade the entire system at once instead of cherry-picking updates.

The general command for upgrading the entire system is pacman -Syu. (However, at the time of posting, the Arch Linux website also has several important announcements regarding recent changes.)

share|improve this answer
    
I'd like to note that it's generally best practice to update any OS approximately once a week, or at least once a month. –  ND Geek Jul 18 '12 at 19:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.