Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Firefox 15 (beta) and I thought that Add-Ons where supposed to by default be compatible regardless of maximum version compatibility. I found this on a website that seems to confirm what I thought:

Default Add-on compatibility – This feature is already integrated in all versions of the browser from Firefox 10 onwards. It basically assumes that Firefox add-ons are compatible, even though their maximum version compatibility may state otherwise.

Or as Mozilla Says:

The vast majority of add-ons work from one version of Firefox to the next without the need for developer maintenance, but under the current system, compatibility information must be updated in order for Firefox to enable the add-on for use. For add-ons hosted on AMO, this is done automatically. However, 75% of add-ons in use are not hosted on AMO, and are therefore a major compatibility obstacle for our users. All of the compatibility effort put into each release is simply because Firefox still assumes add-ons will be incompatible between versions, when they usually aren't.

We should change Firefox's assumption to be that add-ons are compatible, with a few exceptions. Binary add-ons are never compatible between releases and are also the highest risk of negative side effects. Firefox should automatically enable low-risk (non-binary) add-ons in new versions of Firefox, and check AMO for additional compatibility information.

When users upgrade to a new version of Firefox, only the add-ons that are actually incompatible should be disabled, and the rest are assumed to be compatible. Because Nightly, Aurora, and Beta users will test out the add-ons for weeks before stable users, we should be able to identify and blacklist incompatible add-ons before stable users would be affected by a truly incompatible add-on.

I have several add-ons that are telling me they are incompatible with FireFox 15. Am I mis-interpreting what default add-on compatibility means? How do I tell if an Add-On is a binary add-on and/or tell if the add-on is truly incompatible?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Just answering a part of your questions: I cannot give you a way to determine for all addons. But generally speaking, if an addon has a special version for Windows, and another for Mac, and yet another for Linux (or specifies to work only for Windows OR Linux OR Mac), this indicates a binary addon in 99% of the cases. Of course this doesn't say all others are non-binary addons.

And no, IMHO you don't mis-interprete what "default addon compatibility" means -- or I do so as well. As I understand it, it means that non-binary addons should no longer be marked incompatible when upgrading to a newer version of Firefox (even though their "maxver" might state so), and thus should not be deactivated by the update. And my experience is I am right with this (at least concerning my latest couple of FF-updates).

share|improve this answer

All Firefox addons are versioned. That is to say that they list the Firefox versions they are compatible with.

The versioning system allows for future FF version numbers to be included but traditionally, addon developers would only say that their version was compatible with the current (and maybe next if development was far enough along) major version of FF.

Of course, since FF moved to fast releases, this doesn't really work very well any more.

You can easily, manually change the version list since the add-on is actually a zip file in disguise. Simply open the file in 7zip or something similar and you will see a big list of files. Let me know if you want more info on this and I will walk you through making the change. However, there is no guarentee that the addon will work I'm afraid.

There are also addons that allow you to ignore the addon versioning. Try "Skip Addon Compatibility Check 2".

share|improve this answer
1  
as the question clearly explains, since FF 10 this is only partly true (concerning binary addons). Starting with FF10, maxver has more or less informational character, and non-binary addons are "compatible by default". So no more need to "patch maxver" or use "make compatible" addons like Mr Techs Local Install in the "good old times" when major-versions came slowly ;) –  Izzy Jul 18 '12 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.