Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After replacing my old HDD in notebook with new one (Momentum XT 500GB if it matters) I tried to install dual-boot: Windows 7 64-bit and Debian 6.0.5.

I tried to start with Windows, but after successful installation, when I moved to Debian installer, it appeared that it's partition tool doesn't recognize any partision at all (see it as 500.1 free space). Despite my efforts, eventually I had to give up and clean everything up and install Linux on newly partitioned disk.

I hoped that when I install Win7 again I use unallocated space and finish it. But then I saw information that Windows cannot be installed on this partition because it's GPT style.

I tried several times removing partitions with partitioning tools of both installers, creating NTFS partitions with debian but nothing worked and I ran out of ideas.

Is there a way to make visible to Debian installer partitions created by Windows, or to get rid of GPT partition? I really need both systems and I am ready to provide all information needed.

share|improve this question

migrated from stackoverflow.com Jul 18 '12 at 17:54

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Generally speaking, don't install one OS in a partition created by another. Installing Window first always works best. When you install windows, you should see;

200GB NTFS Partition C:/
300GB Unallocated Space

Then the Debian installer should be able to create its partitions in the unallocated space.

Assuming you did all that correctly, you might be having a hardware issue, the debian releases tend to be a bit far behind with drivers. For example, debian was not able to detect my SSD, USB3 or Blu-Ray devices whatsoever. To fix this, I installed debian with a newer kernel (3.something) from debian-backports, and everything worked perfectly.

Check out http://backports-master.debian.org/

And for some handily-packaged installers (I used the USB installer) head to http://kmuto.jp/debian/d-i/

Hope that helps, I can't think of anything else right now.

share|improve this answer
    
I took the hint with hardware issue, and tried to solve problem with RIP Linux. Thanks to that I found out that everything was caused by redundant GPT left by some earlier experiments with other OS. And figuring out how to remove it was easy. –  maddening Jul 18 '12 at 0:52
    
Glad to hear you got it sorted, feel free to answer your own question and tick it, might help someone in the distant future :P –  lynks Jul 18 '12 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.