Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using an application called PuTTY to remote into a server.

I can use it from my local library and many other libraries around me (and also from Starbucks, Panera, etc.) and it works.

But I tried to use it today from my dad's house the same as before, and I get the error:

Network error: Connection timed out. 

What could be wrong?

share|improve this question
    
@ultrasawblade has a great list of what could be wrong. You'll probably have to get into some specifics of your dad's network setup (i.e. test for some of those problems) in order to get specific help. –  JoshP Jul 18 '12 at 22:48
    
Coincidentally, my campus had a power outage (which outlasted the long length UPS on the target machine) at the same time as my apartment. So when the power outage forced me to SSH in from my dad's for the first time, it also knocked the target computer out. Verizon was innocent (but they're still bad at math: verizonmath.blogspot.com). –  Jeff Jul 19 '12 at 2:33
    
Ack! Lol. Glad to hear it was something simple –  JoshP Jul 19 '12 at 2:43
    
:) glad it worked out for you! –  Sandro Dzneladze Jul 19 '12 at 12:15

3 Answers 3

This means PuTTY cannot make a connection to the server.

Possible causes:

  • Verizon is blocking incoming or outgoing traffic/TCP connections on port 22, maybe due to the type of plan you are subscribed to or other reason.
  • Your dad's router or 3G/4G hotspot is blocking incoming or outgoing traffic/TCP connections on port 22.
  • You have no Internet connection and/or something has suddenly gone wrong with the TCP/IP software on your system.
  • Your campus is blocking incoming or outgoing TCP connections on port 22 to/from the specific IP you are connecting from, or one of Verizon's subnets.
  • You have a local firewall or antivirus software that is blocking incoming or outgoing traffic/TCP connections on port 22.
  • Your PuTTY settings are incorrect.
  • Your DNS isn't correctly resolving to your campus's IP address and you are actually connecting to the wrong system.
share|improve this answer
    
Thanks for the rundown. I think I can eliminate 3, 4, 5, 6, and 7 (no i-net connection, campus blocking, local firewall or antivirus, and incorrect PuTTY settings, DNS resolution). How would I check if the router or VZ is blocking port 22? –  Jeff Jul 18 '12 at 22:46
    
Here is a list of public ssh servers: shells.red-pill.eu - I tried the first one and got an SSH prompt. So I now know my port 22 is not blocked. Of course I didn't try to enter a password and actually login, I just wanted to see the SSH login prompt. I was also very polite and did this exactly once ;). Anyway, this way you know if it's specific to anything on port 22 or just connecting to your campus. Next step is to log in to the router and check settings. –  ultrasawblade Jul 18 '12 at 23:51

Putty connects to SecureShell.

Yes it is probably the router/internet connection.

It is rare but some high class routers have ability to drop outgoing connections.

I'm not familiar with Verizon but it is possible they have some kind of proxy through which you connect to internet and this proxy doesn't allow outgoing connection.

I had similar problem at work, work proxy was blocking port 22 (standard port for ssh) what I did is change it to 443 which is https port and it allowed me to connect to my server. To do this change you have to modify /etc/ssh/sshd_config and change default port from 22 to 443 and than connect through that. But this requires you to connect to server in the first place which is impossible I see. Or you could very quickly run to a nearest library modify ssh config file to listen to https port instead of standard 22port and run back home.

But I think your best bet is to call Verizon customer support and ask them about it.

share|improve this answer
    
I'm not sure how to do most of what you suggest. I tried changing the Port setting in "PuTTY Configuration" window, just for the heck of it, and had the same reslt (connection timeout). –  Jeff Jul 18 '12 at 22:48
    
@Jeff Changing it only in Putty doesn't make a difference, you also have to change port on the server. Otherwise Putty is calling number 443 and your server is not answering because it is listening to only port 22. –  Sandro Dzneladze Jul 19 '12 at 6:57
up vote 0 down vote accepted

Simultaneous power outages at my apartment and on campus were the culprit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.