Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have noticed that none of my extensions for Google Chrome are working properly (while they were working before). When I left-click on any of the extension buttons, the menus no longer show up. Whenever I disable all extensions and then enable them again, the extensions start working again (temporarily), but they stop working again as soon as I restart the browser. Also, context menu options for each extension are no longer showing up.

Interestingly, this problem seems to affect both my Windows and Linux Chrome installations, so it appears that this isn't a platform-specific issue. Are there any known solutions to this problem? What is the most likely cause of this issue?

share|improve this question
what branch? dev, beta or stable? Chrome keeps the previous version around, try running that... – cjb110 Feb 8 '13 at 10:38
Could you comment upon the solutions listed in this article. – harrymc Feb 8 '13 at 11:34
Have you tried syncing your chrome to an account, and doing a wipe/fresh install? Perhaps the sync data is bad and it might be good to get a fresh sync going on a new account. – Enigma Feb 13 '13 at 19:09
@Enigma All of my Chrome extensions are working again, and now I don't know why they stopped working in the first place. However, I have sometimes encountered this problem after enabling experimental settings in about:flags. Try reinstalling Chrome if this happens to be the case. – Anderson Green Feb 14 '13 at 0:40

7 Answers 7

up vote 5 down vote accepted

Have you tried syncing your chrome to an account, and doing a wipe/fresh install? Perhaps the sync data is bad and it might be good to get a fresh sync going on a new account.

As you stated, the culprit was likely the experimental settings in about:flags which makes sense. Hard to always see the far-reaching impact changes there might have. Odd that it affected all extensions though.

share|improve this answer

I was facing the same issue. Here is what I did to solve it:

  1. Close the Google Chrome browser

  2. Go to task manager and do "end task" wherever you see "Google Chrome"

That's it. Restart the browser and everything should work properly again.

If this solution is not working for you then disable the extensions, then follow the step 1 and 2, and re-enable the extensions again.

share|improve this answer

I also faced same issue after my computer has shut down unexpectedly. When I restarted my computer, my Chrome extensions, bookmarks, history, cookies etc. stopped working.

I think root cause was that my user profile was corrupted. So i followed steps mentioned in the below link to create new user profile. One important step to remember is that do not forget to take back-up of old Default folder as mentioned in the steps in below link.

Now here comes the trick. I open the browser which created new Default profile and hence all my previous settings were gone. I was worried. I did not wanted to install all extensions again and restore my bookmarks again. So i did the trick.

I closed the browser. I went back to same folder where new Default folder was created. Then I renamed this new folder to "Default - New". And i copied the old corrupted Default folder back again.

To my surprise when I opened Chrome browser, it asked me to Restore the chrome and clicking the button within a second everything was fine. That's trick saved me and so i thought of sharing with other.

share|improve this answer

I would guess one of your extensions was doing something poorly. Then, when it updated itself and fixed the problem, your issue went away.

Next time try disabling and re-enabling one by one until you find the culprit (or a combination of extensions that don't play nice with each other).

share|improve this answer
It's also possible that it happened because I enabled some experimental settings under about:flags. – Anderson Green Feb 14 '13 at 23:33

I get this problem every few weeks. I would disable and enable as you did, but that didn't always work or just worked temporarily. I found one solution on Google that said my user profile probably got corrupted. I followed the instructions and everything came back. However, I did lose my scores in Bejeweled for Chrome. There probably was a way to avoid that but now at least I can hit a high score again with greater frequency. :)

That was a couple of weeks ago and already my extensions stopped working again. However, it was the only thing that solved my Chrome printing problem (after printing to a file, I was always asked for the outgoing file even though I wanted to send it to the printer).

share|improve this answer
please fix your "instructions" link as it is broken. but rather, i would advise to add the core contents of the link to your answer. if the link ever gets broken (it already is tho) so does all your answer. – Lorenzo Von Matterhorn Sep 25 '13 at 8:33
I just tried the link and it worked fine but it may be that the https didn't work if you're not logged in to Google so I changed it to http. If that doesn't work go to and choose Chrome. Right now "Create a new browser user profile" is a link on the bottom of the Fix a Problem section. Or you can search for "create a new browser user profile." – punstress Sep 27 '13 at 16:41

If your windows is not up to date then the extensions will not function properly as before. I had re installed windows on my laptop, when i used google chrome, none of the extensions were operational, but after windows update, I was able to use the services of extensions.

share|improve this answer

type "chrome://flags/#enable-npapi" on the site bar and press enable on npapi. then reboot. Then in the same place type chrome:plugins. Enable Adobe Shockwave player and click the box "Always allowed to run".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.