Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I still own Mac OS X 10.4 (Tiger), but more and more binaries require 10.5 or higher.

During installation the wrong OS version is detected and installation stops automatically.

  1. Is it possible to force installation of 10.5 binaries on my old 10.4 system and try out, if it might work? Or is there no chance to run 10.5 applications in 10.4?

  2. What is the risk? I guess I can just delete most of the apps when I encounter that they do no work satisfactory?

  3. Is there an alternative (Besides source installation)?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

If the apps actually worked on 10.4, I'm sure the software vendor would've allowed them to install there. There are system library differences between 10.4 and 10.5 that will cause app incompatibilities.

No harm in trying, but chances are very probable they will not work on the wrong version of the OS.

share|improve this answer
    
So, I guess, it's time for an OS upgrade :( –  SimonSalman Sep 22 '09 at 13:45
1  
Go right to Snow Leopard. It's worth it! –  EmmEff Sep 22 '09 at 14:06
    
EmmElf: That's not an option if you have a PowerPC mac, and the OP didn't say. –  Powerlord Sep 22 '09 at 14:33
    
In that case, Leopard then... –  EmmEff Sep 23 '09 at 1:06
1  
it's intel, but the upgrade has to wait for now. I will do without that particular piece of software. So, I mark this thread as solved ;) –  SimonSalman Oct 2 '09 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.