Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to create a ramdisk inside a VM. I think I have the ability to use tmpfs, because it is Ubuntu 10.04 which comes with kernel > 2.6. I added this to /etc/fstab:

none /mnt/test tmpfs defaults,user,size=1G,mode=0777 0 0

Then why I try to mount /mnt/test, I get:

mount: wrong fs type, bad option, bad superblock on none,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

What to do ?

share|improve this question
    
Does mount tmpfs /mnt -t tmpfs -o size=1G work? –  Marco Jul 19 '12 at 9:58
    
yes, solved it, thanks. But why ? (the -o option isn't necessary, but the rest is). –  jlock Jul 19 '12 at 11:04
add comment

1 Answer

Unfortunately the Lucid man page doesn't properly tell you the first field for tmpfs.

http://manpages.ubuntu.com/manpages/lucid/man5/fstab.5.html

Replace 'none' with 'tmpfs'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.