Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a tamilnadu govt lenovo laptop which has dual OS boot (windows7 and boss gnu/linux)

In GRUB suddenly the windows 7 changed to windows vista and linux has changed to two versions. If I try booting any OS, I get asked for a username and password. I tried a few usernames and passwords but while I type the password, the characters that I type are not even displayed. yet it gives an error saying ACCESS DENIED. PRESS ANY OTHER KEY TO CONTINUE...

Will the files be deleted trying to solve this?

share|improve this question
I edited your question, feel free to revert the changes or edit the question again but please regard basic punctuation rules. – Baarn Jul 19 '12 at 14:41
I have never used GRUB password protection, but it should be by design that there is nothing displayed when you type to obscure the numbers of characters. – Baarn Jul 19 '12 at 14:43
the fact the characters in password as you type are not shown is common in *nix-based solutions - it's a security design – laika Oct 22 '12 at 11:22

You will need to talk to your system administrator, or whoever it was that sold you or provisioned to you the laptop. Operating systems don't just magically "change" from one version to another, nor do Linux OSes "split" into two versions (although I'm guessing the reason you see two instances of Linux is that you upgraded the kernel, so both the old and new versions of the kernel are present).

If you didn't have to enter a GRUB password before, and now you do, then it's possible that the government has remote admin access to the laptop and they decided to impose a password for whatever reason -- whether it's to lock you out, improve the security of the device, or any other reason. Again, to resolve this, you will need to contact them.

If your goal is to try and bypass the password prompt without actually knowing the password -- I would advise you not to do that. If you are indeed the legitimate owner or operator of this laptop, then the provisioning organization should be able to provide you with steps to successfully boot the system.

share|improve this answer

Even I have faced similar situation in my laptop too. For the GRUB ,

username: boss Password: password

worked for me. Ofcourse while typing the password, it didnt appear even as dots for me..But it worked.

share|improve this answer
thanks for your help.. But I was too late to see this .. i have already installed a new OS. – AntonyStinil Silvester Dec 1 '13 at 14:32

If you need to change the GRUB password, I would advice you to

  • boot from a live CD of your choice, and alter the grub.conf and
    • remove the lock from OS definition block or
    • remove the password global option.
share|improve this answer

For logging into either OS, use the username that you changed in Linux or boss and root combinations.

So, one of these:

  • username: boss, password: boss
  • username: root, password: root
  • username: boss, password: root

Last one worked for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .