Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a huge load after install Linux Ubuntu 12.04 My machine now is a Intel G620/4G RAM/ 1T HD, before it was a Amd X2 5000/4G RAM/250G HD

Now

uptime in idle mode:

 12:45:03 up 3 days,  4:29,  6 users,  load average: 10.90, 10.70, 9.84

uptime in normal use (doing the same things that I do in machine before):

 12:53:03 up 3 days,  7:29,  6 users,  load average: 51.19, 49.11, 47.18

which is almost impossible to use

Top reports

top - 12:53:19 up 3 days,  4:37,  6 users,  load average: 11.11, 11.10, 10.37
Tasks: 223 total,   2 running, 221 sleeping,   0 stopped,   0 zombie
Cpu(s):  6.5%us,  2.8%sy,  0.0%ni, 90.7%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   3960548k total,  3466308k used,   494240k free,    79928k buffers
Swap:  3905532k total,    75632k used,  3829900k free,  1432404k cached

What can I do?

share|improve this question
add comment

3 Answers 3

up vote 0 down vote accepted

What I find strange is your CPU usage is actually quite minimal. Which that in mind, what I find even stranger is that your disk wait (%wa) is 0.0 when you have a significant amount of swap space usage.

Assuming your swap space usage is causing the slowdown (perhaps there was no IO wait at the specific time you took that top snapshot), since you have plenty of free memory try clearing your swap:

swapoff -a
swapon -a

Wait a few minutes for the load averages to re-calculate and then re-evaluate.

share|improve this answer
    
Hi Garret, thank you for your tip. Anyway it's normalized now, and I don't know why. But probably related with one of these packages I upgraded –  Claudio Bastos Jul 20 '12 at 15:56
add comment

That high load (without cpu usage) seems to be related with some of these packages.

 apport
 apport-gtk
 bamfdaemon
 desktop-file-utils
 doc-base
 gir1.2-gst-plugins-base-0.10
 gir1.2-gst-plugins-base-0.10
 gnome-menus
 libc-bin
 libtiff4
 libtiff4:i386
 mesa-utils
 python-apport
 python-problem-report
 python-ubuntu-sso-client
 shared-mime-info
 sysstat
 ubuntu-sso-client
 ubuntu-sso-client-gtk
 ureadahead
 xkb-data
 xul-ext-ubufox

After upgrade Ubuntu, load is now normalized (stills a little high ~1.1) Don't really know wich one fix it. But list all of them wich were upgraded in the time I note the change.

Hope it helps

share|improve this answer
    
It could have been apport. I just experienced another case where apport kept raising my load to 20, then 30, and so on, by using 100% one of the 4 cores. The workstation was quite usable though. Normally, this should not happen. Should be a bug on apport (or something curious that makes the cpu load counter go crazy). –  user156914 Sep 7 '12 at 11:32
add comment

Check your hard drive using smartctl for bad sectors or pending sectors.

Load average will go through the roof if the drive is flakey and trying to recover bad reads, because the LA is calculated as what's in the run queue PLUS whatever's waiting for IO.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.