Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm basically asking this question:

When I press Win+L, the “Locked” screen (with the password prompt) appears immediately. That’s nice, but not terribly important: I’m probably leaving the computer anyway.

But after I type the password (to unlock the workstation), the desktop doesn’t appear immediately: instead, the “Locked” screen slowly fades out, the desktop slowly fades in, wasting my time, and all keys (e.g. Win+R) pressed during this interval are completely swallowed, forcing me to wait unnecessarily. This is extremely annoying because when I unlock the workstation, I generally want to use my computer.

How do I disable this fade out/fade in effect and have the desktop appear immediately, in the same way that the “Locked” screen appears immediately?

I'm asking again because the aforementioned question didn't have any useful answers, but an answer was accepted anyway. I would like to know if any new findings have been made since that question was asked two years ago.

For me, though, I have my login background the same as my desktop. When it fades out, it removes the coolness that I get.

share|improve this question
3  
Actually the other answer says it isn't possible... –  imtheman Jul 20 '12 at 0:26
1  
2  
Welcome, please don't ask the same question again. Check out the FAQ, specifically bounties, for options on how get newer/better answers. :) –  Ƭᴇcʜιᴇ007 Jul 20 '12 at 0:30
    
@PeterMaxwell I didn't know if there was a new way of doing it from a windows update or something. –  Chipperyman Jul 20 '12 at 1:56
2  
chipperyman is new... not get 75 rep, not rep to comment; that does not make it okay to open a duplicate. Like techie said, that's what bounties are for, and if a user does not have enough rep for a bounty, then that's what Meta is for: to address issues like this. Closing an older question as a duplicate of a newer one just seems messed up. –  Synetech Jul 20 '12 at 13:36

5 Answers 5

up vote 4 down vote accepted
+50

(Posting this as an answer so later visitors can see it better.)

Based on the comments above, it seems there's no way to remove the fade in on screen unlock. It seems that the fade-out/ fade in animation is actually covering for Windows doing something when it unlocks the screen (much like the black flash you get if you hit control-alt-delete between the normal desktop and the lock menu). If there was no animation, the lockscreen would probably not take any less time to enter or exit, it would instead appear to hang for anywhere from half a second to a couple of seconds (depending on your computer) on a black screen. That is, the animation itself isn't the source of the delay, it's an attempt by Windows to mask the delay.

share|improve this answer
    
Thank you, that's what I figured, I made your answer accepted because it was said best from you. –  Chipperyman Aug 4 '12 at 21:42
    
I suppose the final answer is 'Its not designed to do that'. I am very meh about that –  Journeyman Geek Aug 5 '12 at 11:35
    
That's too bad, because it creates a very uncomfortable flashing on my system I have a 2560x1440 screen, and my desktop background is dark, so for a second or so after typing the password in the logon screen, there is a nasty flicker :/ –  user30033 Sep 18 '12 at 4:09

Change two settings:

  1. Go to > Control Panel > "Performance Information and tools"

    enter image description here

  2. Click on "Adjust visual effects"

    enter image description here

  3. De-select the items with "fade"

    enter image description here

  4. Go to > Control Panel > "Appearance and Personalization"> Ease of Access Center then> "Make it easier to focus on tasks" page

    enter image description here

  5. Check "Turn off all unnecessary animations" option, Found under the “Adjust time limits and flashing visuals”

    enter image description here

Restart: Should work...

share|improve this answer
    
That does disable some effects, but not this one. –  Chipperyman Jul 31 '12 at 0:34
    
Ok.. too bad. If this didn't work, IMHO, I am not sure it is possible –  Fergus Jul 31 '12 at 3:10

I was looking for this too, and sadly, this isn't possible as of yet. it's a major disappointment, but there is no system option or registry value that controls this. it would likely need a modification of system files, which nobody has done yet.

share|improve this answer
2  
I can only confirm this. I captured a Process Monitor log while locking and unlocking the workstation, I inspected all reads of LogonUI.exe (the process that handles the log on). There is nothing indicating that LogonUI would read any external parameter that controls this behavior. Unless I missed something, of course... –  Oliver Salzburg Aug 4 '12 at 17:02

You can change your logon screen and there's plenty of other tweaks for Windows 7 in this websites home page:

http://tweaks.com/windows/39167/change-the-logon-screen-with-logonstudio/

share|improve this answer
    
And have you used it to actually make Windows behave as the OP wants? –  Ben Richards Aug 3 '12 at 22:24
    
I have seen others successfully modify String Tables and other resources in 32/64bit Windows executables and dll files. It allows you to view and modify them as decompiled resource scripts, so all the OP has to do is locate the settings file which controls fading and disable it. –  FrankComputerAtYmailDotCom Aug 4 '12 at 1:18
    
I have seen such a thing as well. I've done it before (with Visual Studio). I've also programmed. While you can see string tables, it doesn't guarantee that you'll see anything that controls the fade-in and fade-out behavior. There's a lot more to those files than what you see in the resources. –  Ben Richards Aug 4 '12 at 1:54
    
I don't think this will help... basically what you're saying is that there's a file somewhere that will edit some file, but you aren't telling how to use the program or what file to edit. –  Chipperyman Aug 4 '12 at 2:04
    
The executable that controls fade and other display settings is in C:\Windows\System32\SystemPropertiesPerformance.exe You might also want to take a look at login.exe and USER32.exe in the same folder. If you want to learn how to use reshack, I suggest you download it and read the docs. –  FrankComputerAtYmailDotCom Aug 4 '12 at 3:37

To avoid screen flicker when unnecessary animations turned off, I went to: Control Panel\Appearance and Personalization\Personalization and chose "Windows 7 basic".

share|improve this answer
    
Seems a bit extreme to me –  Lee Taylor Dec 2 '12 at 18:00
    
That could cause you to lose every other effect. –  Chipperyman Dec 8 '12 at 3:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.