Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Windows Server 2008 R2 Standard servers. The first can correctly sync its time with the default NTP server time.windows.com, but the second cannot.

The error displayed is:

An error occurred while Windows was synchronizing with time.windows.com

I installed Wireshark on both, and tried an NTP sync. On the working server, I can see the NTP request, and the NTP answer. However on the second server there is no NTP request (Wireshark sees nothing).

The filter I applied in Wireshark is simply "ntp".

I tried to restart the Windows Time service, and disabled the firewall but the problem still persists. How can I fix it?

share|improve this question
add comment

1 Answer

Youd want to take alook to this:

I get "An error occurred while Windows was synchronizing with [name of time server]." when trying to automatically synchronise PC time

You can add a new rule to SPF following the steps delineated here. The application is w32Time located under System32 is memory serves right.

However if SPF doesn't complain, the problem is certainly elsewhere. I see to remember having had problems with time sync before. I really can't remember what the reason was in end. But two things seem to nag me:

The service was stopped or in Manual or something, and needed to be in Automatic(?). My router was blocking it Errors coming from the time servers alone seem unlikely. As you say you have tried others. But in any case KB262680 contains huge lists of time servers you can use.

Meanhile KB314054 reveals manual configuration instructions of the service in the registry along with a detailed explanation of all keys further down the page. Could be a case of a bad registry configuration.

All the best.

share|improve this answer
    
Hi,Thank you for you answer.I saw this post before. I tried to set the service in "automatic", but it's the same. Both server are exactly in the same LAN with the same rights and access. I will try the KB314054 , but I don't think it will help me... keep you posted –  vercetty92 Jul 20 '12 at 13:18
    
I confirm it doesn't change anything...whireshark doesn't seen any attempts.....the service seems completely broken –  vercetty92 Jul 20 '12 at 13:33
    
Im going to keep looking but that's all I've found. That, and to restart/unregister/register the w32tm.exe,change CMOS battery and that port 123 needs to be open (123 udp Network Time Protocol (NTP) - used for time synchronization). –  Rhyuk Jul 20 '12 at 13:45
    
@Rhyuk You can add a new rule to SPF. What is SPF? –  Pro Backup Jun 28 at 11:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.