Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wrote a /bash script and to execute it I decided to set all the rights, so I tried

chmod 777 * //I had 3 text files in the directory, so that's ok

Then to check the result I typed

ls -l

But the rights hadn't changed at all.

I haven't got any error messages and it seems strange. I also tried to specify full path, but this hadn't helped.

I also tried to do all of these steps under root

Where may be the problem?


Thank you for help!


ls -la

drwx------ 1 gemma gemma 4096 июля  20 18:00 .
drwx------ 1 gemma gemma 4096 июля  20 16:35 ..
-rw------- 1 gemma gemma  407 июля  20 18:00 buildedfile.out   ;this is what I
                                                               ;need to launch
-rw------- 1 gemma gemma 4096 июля  20 17:21 kernel.bin
-rw------- 1 gemma gemma  350 июля  20 16:59 link.ld
-rw------- 1 gemma gemma 2025 июля  20 17:59 main.c
-rw------- 1 gemma gemma 1894 июля  20 17:34 start.asm
-rw------- 1 gemma gemma  457 июля  20 17:20 start.o

That is what ls shows after all I tried


I rebooted PC and problem rose again. But now any of suggested methods doesn't help.


I'm using Linux Mint 13 32-bit. On main disk where this files are located I have ext3, also tried on two another partitions where I have ntfs and FAT32.


buildedfile.out is a terminal app written on C

share|improve this question
    
Did you get an error from the chmod command? –  Fran Jul 20 '12 at 14:45
    
did you try chmod 777 /path/to/folder/* –  Sandro Dzneladze Jul 20 '12 at 14:48
    
Please post the output of ls -la –  deppfx Jul 20 '12 at 14:59
    
Try the verbose switch: chmod -v 777 * –  Dennis Jul 20 '12 at 15:23
    
You can also try chmod a+x * (or even better chmod a+x buildedfile.out) if that works and you just need to execute a file maybe it's only the 777 thing wich causes trouble :/ –  epingle Jul 20 '12 at 15:25
show 3 more comments

2 Answers

Try: sudo chmod -R -f 777 *

I think that can be a permission issue.

share|improve this answer
add comment

Are you sure your filesystem is not mounted read only ?

Type mount command to check. if there is ro in the mount options, you need to remount your filesystem with the following command :

mount -o rw /dev/ /mountpoint

You can also check which user owns the shell script.

If it's not "gemma" it could be the cause of the problem.

share|improve this answer
    
I had a similar issue and it was indeed a problem of my HDD caddy being correctly mounted. I solved it following these steps askubuntu.com/a/168424/20868 –  George Mauer Nov 11 '12 at 17:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.