Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Batch-convert files for encoding or line ending under Windows

Hey!

I have many files that are encoded in the ANSI (iso-8859-1) format and I want to change it to utf8.

I am converting one by one using notepad++ but I was wondering if there is any application that will convert them all (I have many files) in a quick and easy way.

Anyone know of one app that will do this?? (free app would be great)

Thanks

share|improve this question

marked as duplicate by quack quixote, Arjan, Diago Feb 25 '10 at 18:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

This is a perfect fit for a scripting language to convert Windows-1252 to UTF-8.

share|improve this answer
1  
iconv does the job without any nonsense. –  Charles Stewart Jan 18 '10 at 10:28

You could try this SourceForge app. From the website:

Codepage Converter - Convert HTML/Text files to different encoding formats e.g. ANSI to UTF-8 or Unicode. Convert multiple files with 1 click. Works with all encodings

share|improve this answer
    
Thanks for the app, but I don't think it's working. I can see the file as ANSI in notepad++ :( Maybe this encodes text, but what I really want is the encoding of the file –  AntonioCS Sep 22 '09 at 14:45
    
Tried it right now; true, Notepad++ still tells me it's ANSI. Very strange... –  alex Sep 22 '09 at 14:52
3  
That's because the program does not mark the files with a BOM at the top, which "tells" Notepad++ the file is UTF-8. It's a Windows thing. to fix it, go to Settings -> New Document/Open Save Directory. Then change the Encoding to "UTF-8 Without BOM", and check "Apply when open ANSI file". Googling will tell you a lot about why you need to do this, and why BOM's are bad (Wikipedia is your friend). –  Breakthrough Sep 22 '09 at 15:39

A bit late, but: If you saved your scripts as 'UTF without BOM' and notepad++ is now opening them as ansi -> you can 'fix' this behaviour by including a string of multibyte characters somewhere in your comments to force notepad++ to recognise the UTF encoding of the file. It's a complete hackjob, but it works ;-)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.