Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This machine has been upgraded recently to Lubuntu 12.04 from 11.10. The OS is 64bit.

I had SublimeText installed, and it's the kind of software that you download it to a folder and run it simply by double-clicking on the main binary.

Now, I double click the binary file and it simply does nothing. No warnings, no errors. Also, when I right-click the file to view its permissions, click to Properties, it doesn't open the file properties dialog. Without errors or warnings, either.

In Terminal, i see that the file has -rwxr-xr-x permissions. From the Terminal I can execute the software by writing: ./sublime_text

SublimeText was downloaded before upgrading. Now, I downloaded FileZilla to try with it, and it happens the same.

I have created a shortcut that executes ./apps/sublimetext/sublime_text to run the app from the desktop, and this way it works.

Does anyone have any clues and how to solve it?

share|improve this question
    
Have you this problem with all of your binary files or just this one ? If the problem occurs with more of your binaries, that seems to be a problem with your desktop environment. Do you know which one your are using ? Put the output of ls -l /usr/share/xsessions/ here if you don't know. Once you'll know your desktop environment the problem must be an incorrect config file or a correct config file which doesn't match your preferences ^^ – epingle Jul 20 '12 at 15:53
    
thanks epingle, apparently, it has somehow been fixed automagically in some system update (??) – Tony Aug 10 '12 at 8:46
    
Haha okay, nice ^^ – epingle Aug 10 '12 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.