Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Summary

Emails sent from a Thunderbird identity I retain the 'from' address of the original gmail account.

Explanation

I'm using Thunderbird 14 on a portable installation with Google as provider, Lightning and Mail Merge. I have set up a Thunderbird account with different identities. I have another account (communty@gi--etc.com) which forwards to my Gmail account (gjlewis37@gmail.com). I have set up an identity on my Thunderbird account which has the email and reply to account set to community@gi--etc.com.

So I select community@gi--etc.com in the 'from field' when sending emails. However, any emails I send like this from community@gi--etc.com appear to recipients as sent from gjlewis37@gmail.com, although it keeps the identity specific signature but not the 'sent from' field.

The precise set up for my Gmail alias community@gietc.
The problem remains the same if I leave the reply-to field blank:

enter image description here

Yet when I send emails like this, although the signature remains, the email is sent 'from' my Gmail, and not the identity:

enter image description here

share|improve this question
    
I am a bit confused by the number of email addresses that do not match between your question and your screenshots. Please clarify your question. For now I recommend to try to save a draft of a mail you compose with your problem identity and see if the address is already wrong before sending. –  Gurken Papst Jul 20 '12 at 16:53
    
@Gurken. Thanks for your tip on looking at drafts and sent mail. I have manged to solve this problem myself. SOLUTION: Gmail will not send from other email addresses until an alias is set up in gmail, regardless of identities set up in thunderbird: it will channel all outgoing traffic through the original gmail address. Setting up the email address I wanted to be sending from as an alias in gmail solved the problem. –  Gregory Lewis Jul 20 '12 at 22:34
    
If you can answer your own question please write the solution as an answer and accept it (might take a few hours until you are allowed to accept). You should check the FAQ, too. –  Baarn Jul 20 '12 at 23:11
    
Ok, now I understand what you were doing. Is there a special reason to send these mails through Gmail? If not, you also could just set up another SMTP account in Thunderbird for your community address with the correct SMTP server and select that in the identity configuration dialog. Remember that Google will add a Sender field in your mails revealing your Gmail address. Submitting mail through foreign servers can cause false positives in spam detection, e.g. when the domain has a strict SPF record. –  Gurken Papst Jul 21 '12 at 11:28

1 Answer 1

Transfer (unregistered) OP's old solution to answer.

Gmail appears to ignore all aliases not set via Gmails own 'add another email address you own' function under 'accounts', so all outgoing traffic from Thunderbird under an identity is funneled through the original Gmail account.

Adding the address through Gmail (settings -->accounts and import --> add another email address you own then follow instructions) solved the problem: emails sent in Thunderbird under the identity appear to recipients as sent from community@gi--etc, and not gjlewis37@gmail.com

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.