Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I didn't notice another discussion regarding this problem I have been having so I figured it would be safe to ask.

I have just recently installed Mysql database and workbench on a computer. I open up the workbench to establish a new connection to the database on the localhost and I test the connection - Mysql workbench suggests that the connection parameters are correct. So I go back to the main Workbench program and click on the connection I just made so I can start creating tables and filling them out graphically. But when I click on the connection it shows the splashscreen and then tells me "Connection Cancelled" in the status bar on the bottom. I am able to right click on the connection that I just made and start the command line client and edit it that way.

What gives? I don't think I have permissions issues missing since I am able to get to the command line console...

I am running Windows server 2008 r2

Thank you,

share|improve this question

I had exactly the same issue on the same server configuration. In my case I fixed it by changing the server in the connection string from "localhost" to "". i.e. your guess at localhost resolution worked for me.

share|improve this answer
up vote 0 down vote accepted

A resolution, more than less. I am still unsure on why I am kept from being able to access the localhost mysql database, but I was able to connect to it remotely no problem. Perhaps its some stupid Microsoft firewall or localhost resolution issues. Who knows. Someone has an answer to that i'm all ears.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .