Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I just bought a new laptop, installed Google Chrome, and discovered to my dismay that when I try to do what I normally do to perform a search, Google Chrome is acting wonky.

To normally search on every other computer I use, I start typing google in the adress bar, when I get to goo (usually), I'll hit TAB to enter "site search mode". Chrome is being a jerk and trying to take me to a page that is in my history.

I've tried clearing my history to see if that would fix it, but it still won't seem to work.

So, what can I do to make "search in site" work for Google (when it works by default for every other installation of Chrome)?

share|improve this question
2  
You know, you can just type a search into the bar without "goo" or anything in front of it? i.imgur.com/Wfk8i.png –  Oliver Salzburg Jul 20 '12 at 23:13
    
I know, it's just a habit that I can't seem to break. :) –  Eric Ryan Harrison Jul 21 '12 at 11:51

1 Answer 1

up vote 3 down vote accepted

Go to chrome://chrome/settings/ then Manage Search Engines and in order for feature to work it must be added to the list of search engines. Chrome typically adds it automatically once you visit the site though.

share|improve this answer
    
That did the trick. Thanks so much. –  Eric Ryan Harrison Jul 21 '12 at 11:51
    
Tab search in Chrome stopped working for a site that had previously worked. I removed the site from the list and visited it again. Works again. I assume the site changed and chrome was using an old URL or something. –  Samuel Nov 18 '13 at 22:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.