Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I installed an old Wacom USB tablet just for fun, to see if it worked with Vista, and it did, since I've found a working driver.

The only thing annoying me is that now my laptop has been setup as a tablet, and an on-screen-keyboard is shown at the logon.

Not really an issue, but since I've googled around and found no answer apart from disabling all the tablet features entirely I was wondering if there was a registry hack-around to disable this behavior.

share|improve this question

5 Answers 5

control panel > ease of access > use the computer without a mouse or keyboard > clear 'onscreen keyboard'

share|improve this answer
    
unfortunately that is already unchecked. but still, thank you –  evacchi Sep 22 '09 at 16:56
    
This was already set for me too. I found that toggling the setting fixed the issue. Toggle it on, then off again. –  SliverNinja Jul 9 '14 at 2:07
up vote 2 down vote accepted

The answer was actually in the comments of the link I posted in my question

Control Panel > Type “Device Manager” in search contents box > Human Interface devices > Wacom HID > Disable Wacom Virtual HID driver.

You’ll still keep pressure-sensitivity in applications with your tablet, but this got rid of my on-screen keyboard completely after I disabled the process.

I'm still investigating on any side-effect. By the way this seemed to do the trick, and it can be reverted back!

share|improve this answer

I found something on a forum that seems your logical options:

I wanted to share another workaround I found (out of desperation) after installing my Wacom Tablet and dealing with the persistent appearance of the on-screen keyboard.

I went to:

  • Start
  • Windows Help & Support
  • System Info
  • Software
  • Installed Programs
  • View enabled Windows features
  • Tablet PC Optional Components and I unchecked that box.

Since I don’t have a Tablet PC and only have an installed tablet, I thought there might be conflicting drivers.

When I rebooted, the on-screen keyboard at logon had been eliminated. My Wacom tablet works great and the on-screen keyboard has disappeared. This action doesn’t appear to have disabled anything I use on a regular basis, and everything seems to be working fine. The solution may not work for anyone else, but it has for me.

Or try these options:

Here are a few things to check ...

First, go to Control Panel, Ease of Access. Then click on the link "Use the computer without a mouse or keyboard". Make sure the checkbox marked "Use On screen keyboard" is UNchecked (ie, clear).

That's your first and most important place to check. After that, it gets a bit more obscure. The On Screen Keyboard program is "osk.exe". Presumably something is causing osk.exe to be run, every time you log in.

In the Start menu, look in the Startup folder. Make sure there are no shortcuts there pointing towards osk.exe. If there are, move the shortcut to another location, or just delete it.

Next, run the command "msconfig". If prompted for admin credentials, enter them. Then, look under the Startup tab. Look for any entries which appear to run osk.exe. If you see one, uncheck teh entry, and then press Apply.

Next, run Regedit. If prompted for credentials, enter your own, current username and password. Then navigate to the registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

If you see a value under there which runs osk.exe, delete that value.

If you've looked at Ease of Access, the Startup folder, the MSConfig startups, and the HKEY Current User Run key, and you don't find the osk.exe Onscreen keyboard anywhere in any of them, then ... sorry, I really don't know. Maybe someone else will know. Or else, learn to enjoy having an On screen keyboard! :-)

share|improve this answer
    
unfortunately the first solution is what I wanted to avoid (provided link); as for the second, the osk.exe is a user mode process which is started after the logon, so it's not related but thank you anyway! –  evacchi Sep 22 '09 at 16:55

I'm four years late...but here is the likely culprit:

regedit.exe ->
local machine ->
software ->
microsoft ->
windows nt ->
winlogon (winlogin?) ->
system=osk.exe

Delete the system entry.

share|improve this answer
    
Your post is hard to read. Could you use -> separators to clarify the registry path? –  Kazark Apr 19 '13 at 20:24

For me, using a Cintiq 13HD, simply go to Control Panel > Tablet PC Settings > Other (tab) > Go to input panel settings - Uncheck everything on the first tab.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.