Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried to connect the hard drive with two different enclosures and it seems to be working because it installs all the drivers and says my device is ready to use. But after that it doesn't pop up or show up on my computer. (IDE harddrive) (windows 7)

Any thoughts on what i can do?

share|improve this question
1  
Can you try it on another system? Can you try a different drive in the enclosure(s) to make sure they work? Have you tried connecting it internally to make sure it’s good? –  Synetech Jul 21 '12 at 14:54

1 Answer 1

First of all some background: A hard drive is never supposed to show up. Partitions on a hard drive usually show up though.

Which yields the first thing to check: Are there any partitions on it?

You can check this easily via

  • Right click my computer
  • Select manage
  • Look for Disk management under the header storage.

If the HDD is new you might need to add a partition table and partitions. If it is not new and contains FAT/NTFS partitions then check if they have drive letters assigned to them. You can do this by right clicking on the drive and selecting Change drive letters and paths

If this do not work then put the drive directly into a computer. (After all, the drive itself can be broken.)

share|improve this answer
    
No just data and i already have tried to see it in disk management but it still doesn't show up. I just wanted to get the data off but yeah i think the drive is broken (just wanted to make sure before i declared it garbage) –  tko123 Jul 21 '12 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.