Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm completely stumped by this. My simple use case is that when I'm in bed, I use a cordless mouse to browse the web, watch videos, etc. - the monitor is across the room. When I'm going to sleep, I want to shut the monitor off. I also want to be able to turn it back on in the morning. I just want to turn the monitor off and on using only the mouse.

I thought of creating a power setting that turned the monitor off asap (the shortest amount of time is one minute; that's fine). I have one that does this. It worked great for almost a year on my old XP machine, and for about four months on my new Windows 7 laptop (which I essentially use as a desktop). All of a sudden a couple weeks ago, it just stopped working - my monitor won't turn off on its own anymore. Here are the settings:

enter image description here

I tried other options. Based on the advice here I tried nircmd. This seemed great. I created a shortcut with the command line:

"C:\Program Files\nircmd\nircmd.exe" cmdwait 1000 monitor off

I click this, and in one second the monitor goes off. However about five seconds later it turns back on, and I've been extra careful to make sure the mouse isn't moving.

I have no idea what's going on. Based on both of these things, my only guess is that something could be running in the background which somehow makes the computer think it's in use. I've tried killing as many programs as possible but I still get the same behavior. Any advice? I'm mainly curious about how to debug, but am open to other suggestions about turning the monitor off and on with just the mouse as well.

share|improve this question
1  
can you turn the mouse off so that it can be ruled out as the cause? –  Jakob Weisblat Jul 21 '12 at 17:13
    
Well, this is bizarre. It's a cordless USB mouse so I tried two things. First, I clicked the shortcut for nircmd, and immediately unplugged the USB receiver. It worked! The screen stays off. However, when I switch to the "turn off asap" power profile, and then unplug the receiver, it still won't turn off. But seriously, this mouse is not moving - it is perfectly still, on my desk, and I'm going to great care to just push the button as quickly and quietly as possible... –  Jer Jul 21 '12 at 17:21
    
And one other thing I just tried - I kept the mouse still and didn't even touch it, and then ran the nircmd command using just the keyboard from a command prompt. The mouse is not moving - it's across the room. Still, the monitor turns right back on. –  Jer Jul 21 '12 at 17:23
    
Another test - I changed the nircmd command to turn the screensaver on, and set up a "blank screen" screensaver. This works as expected - I click the shortcut, and the screen goes blank and stays that way until I move the mouse. This is ok, I guess, but not ideal because there's still a bit of a glow coming from the monitor (a blank screensaver is still brighter than the monitor being off). So I can pretty safely say it's not the mouse that's moving, unless there are different "thresholds" for being "awake" for the monitor being off vs. in screensaver mode. –  Jer Jul 21 '12 at 17:35
    
The threshold for the screensaver is, as I remember, higher than the threshold for the monitor on. Is there no switch on the mouse for on/off? I would think it would have that to save battery. –  Jakob Weisblat Jul 21 '12 at 17:41

5 Answers 5

Have you checked this?

Power Options advanced settings

If I recall correctly, I also had issues with the computer (also Win7) waking up on its own until I put "Allow wake timers" on "Disable." I don't understand completely what it means, but it worked, and I haven't looked back since.

share|improve this answer

If a proper Display Driver not installed, the display can not turn off.... Power management features won't work without a proper video driver.... The VGA driver is the most important driver!... (usually vital Chipset drivers almost always comes with Windows these days). That problem is a huge one....

But in this case it is not the problem. If the display goes off at least for a second, that means it can and it is not that problem. A problem related to certain device or processes i guess... First check the devices.... Then processes :) Some processes wake up the display and some does not let the display to go off.... (Certain Media Players are common examples).... Here you can examine all opened programs and opened Processes. Use NirCMD shortcut to test.... First test after exiting ystem tray programs. Then test by killing non vital, non critical system processes and test.... If success, then next time do the test dividing the group into smaller groups instead of big 2 to find out the actual thing that cause this :)

share|improve this answer

Probably another device is still active, that happened to me and caused me to be unable to hibernate.

Basically you've got another hardware bit telling your computer to turn on, could be a USB game controller, could be a network cable, the fastest way to check is to unplug everything, but a more permanent solution is to disable 'wake up' from these devices.

I cannot elaborate more on the process as I'm far from a computer (hopefully another user will edit my answer to be more complete) but from what I remember you should be able to disable device wake up from the Device Manger.

share|improve this answer

I have the same problem on an Ubuntu box - monitor won't turn off because the visualisation is moving. But you said you tried shutting down every program and still the magic is not happening.

@Jake223's idea is worth pursuing. Use a corded mouse. Unplug the receiver and then try the power off profile.

share|improve this answer

I use my computer in place of a TV, so I like to watch it before going to sleep. Unfortunately my current monitor is a computer screen and has no remote. I've gone through many the same things as you, I settled on nircmd for the monitor off. I have two mice plugged in to my computer at all times (It used to be three + two keyboards) I'm a gamer so I don't believe in using wireless mice while playing due to untimely battery deaths and the like.

When I run nircmd from a wireless device (Be it keyboard or mouse) I experience the same thing as you. The screen goes black for a few seconds then it just comes back on. However, when I use a wired device it works perfectly EVERY time.

My solution: Try Wizmo (Windows Gizmo) which is similar to nircmd. In much the same way as nircmd, put wizmo where you want it, create a shortcut for it, move the shortcut to the desktop, change the Target by putting quotes " " around the patch ("C:/wizmo.exe" for example) then put a space followed by: wizmo monoff shake=99

This will eliminate the minor mouse "shake" that a wireless mouse seems to have from turning your monitor back on, while allowing you to still wiggle the mouse a bit to turn your monitor BACK on. Wizmo does come with a small chime but that can be fixed with some more bits added to it (I changed mine to a different sound entirely) This fixed my problem. Such a nightmare trying many different things.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.