Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an AMD TL-60 mobile processor. I've noticed that often when I watch videos, I get a really jerky playback. I can fix it if I run the following command:

echo 2000000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq
echo 2000000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq

For some reason, these values get set to 800000..even though I'm using the CPU to play video. The script helps the video playback for a while and then things go bad until I run the script again.

It appears that my laptop is a hippie and is trying to save power at the expense of being useful. I turn it off when I am not using it, but when I do have it on, I need to actually do stuff. How do I properly indoctrinate my laptop to always run at full speed?

I'm running Ubuntu 12.

share|improve this question

migrated from serverfault.com Jul 21 '12 at 19:25

This question came from our site for system and network administrators.

    
Should be on Superuser.com – DKNUCKLES Jul 21 '12 at 19:20
1  
does throttling happen when plugged when on AC adapter? – BrianAdkins Jul 21 '12 at 19:21
1  
+1 for being a hippie – Joe Taylor Jul 21 '12 at 19:40
    
Turn off all cool & quiet features in the BIOS – Bon Gart Jul 21 '12 at 20:57
    
AC adapter is plugged in at all times. – User1 Jul 21 '12 at 22:25

I think I solved it. I ran the following command:

echo performance > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor

And then the two other commands in my original question. It seems to work fine until I sleep the laptop. I'm wondering if the scaling governor was really set to rick_perry.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .