Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a very strange problem. I tried to install Linux on an old computer, but no Live CD would boot except Knoppix.

After several attempts, I got to nearly booting Linux Mint Debian edition, and managed to run the Debian (not LMDE, the Debian DVD) installer. However, the Debian installer is extremely slow and as such I decided to run it tomorrow (it's about 5pm).

Here is the link to my post on the Mint forums (to settle out the possible misunderstandings and extra hardware information).

Note that when doing the system profiling on the link I had a Gigabyte GeForce GTX 580. I went back to a GeForce GTX 480 (that's part of what let me boot Debian at all).

Technically I'm getting a new PC in about 2 months, but I want to find out the problem with this one first to avoid having the same problem on the new one. (Going to shop with a Linux CD should freak quite a few people out... I like that but it would be my last resort. Especially considering I'm planning on building it...)

share|improve this question
    
Have you tried an ubuntu alternate installer cd, or some other non livecd? –  Journeyman Geek Jul 21 '12 at 22:15
    
An E6600 isn't that old. But you haven't described what the actual problem you're having is. –  Michael Hampton Jul 21 '12 at 22:19
    
The problem is that I can't boot any liveCD (kernel loads and that's where it ends). I've tried multiple things including a debian DVD installer. Please read the link on the mint forums, lest I copy all that info in here making this about a page long @_@ –  Shingetsu Jul 21 '12 at 23:16
    
If your pc has a built in video card try booting with just that. core2 should be more then enough to boot any of those. WO an error message its tricky to say. I have a barton which is probably 2+ years older then the core2 running fedora 17 and solaris 11. The realy new video card is the only thing that sticks out, could be that the open nvidia driver on the disks doesnt have an id for it. Im suprised txt mode didnt work which makes video even more suspect. you could try booting with the no framebuffer txt mode. –  Kendrick Jul 22 '12 at 4:17
    
@Kendrick I can boot knoppix, and I tried to install debian with deboostrap. I succeeded the "bare bones install", so no bootloader or drivers yet. However I can't do anything else -> knoppix is 32 bit only (and debian is 64 bit)... So chroot gives a bad exec format to /bin/bash :(( –  Shingetsu Jul 22 '12 at 17:35

1 Answer 1

up vote 0 down vote accepted

I finally settled the issue. Turns out that my BIOS was ~600 version behind (literally). - 3xx to 9xx.

After updating it the only problems remaining was the incompatibility of my nvidia card with nouveau which I settled easily by installing arch and the nvidia drivers without ever touching nouveau.

Lesson in this: Updating BIOS is a good thing.

share|improve this answer
    
...if successful. Welcome to Mint. ;) –  DevSolar Aug 22 '12 at 16:07
    
@DevSolar How is mint relevant at this point? Yes I wanted to install mint initially for a few reasons, but if you look carefully: I settled easily by installing arch and the nvidia drivers . Arch Linux :). And it was, I'm writing from it. –  Shingetsu Aug 22 '12 at 21:30
    
I didn't understand "arch" to mean Arch Linux, and was going from your mention of Mint in the question, and your reference to the Mint forums. Well then, welcome to Linux. ;) –  DevSolar Aug 23 '12 at 6:41
    
@DevSolar once again I've been on it for quite a while ;) . So I'll just write this to my machine: echo Welcome to Linux, dear computer! :) –  Shingetsu Aug 23 '12 at 12:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.