Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I connect to another server using command:

ssh -Y server1

On server1 I add an alias in .bashrc file:

alias gousr='cd /opt/user/myuser'

When I try to run gousr command at server1 xterm, it says "command not found". What is wrong here?

share|improve this question

I tried this and it worked for me. Have you run source ~/.bashrc since you last logged in/rebooted?

share|improve this answer
When I do source ~/.bashrc it says: if: Expression Syntax and the alias still does not work. – alwbtc Jul 22 '12 at 11:03
can you post the part of your ~/.bashrc file that has an if statement? – Jakob Weisblat Jul 22 '12 at 16:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.