Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am debugging javascript on a web page using Chrome Web Developer Tools. On Windows, I can use F11 to step into a function while using the debugger.

However, when I press F11 on my Mac, The volume just increases. F11 + fn doesn't do it either. How can I use Chrome Web Developer keyboard shortcuts on a Mac?

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted
  • Continue: F8 or Command-/ (forward slash) on Mac or Control-/ (forward slash) on other platforms.
  • Step over: F10 or Command-' (apostrophe) on Mac or Control-' (apostrophe) on other platforms.
  • Step into: F11 or Command-; (semi-colon) on Mac or Control-; (semi-colon); on other platforms.
  • Step out: Shift-F11 or Shift-Command-; (semi-colon) on Mac or Shift-Control-; (semi-colon) on other platforms.
  • Next call frame: Control-. (period) on all platforms.
  • Previous call frame: Control-, (comma) on all platforms.

Source

share|improve this answer
add comment
  1. Go to System setting -> Keyborad -> Keyboard.

    Make sure you have Enabled Use F1/F2 as standard function keys.

  2. Go to System setting -> Keyborad -> Keyboard Shortcuts.

    Choose Mission Control on the left panel, then look to the right panel and disable F11 to Show Desktop.

share|improve this answer
    
Coming from Windows to OS X, this is one of the biggest annoyances I have struggled with the past two weeks... Now I can debug properly lol. FANKOOOOOO! –  Gavin Jul 10 '13 at 15:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.