Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About a month ago, Google Desktop stopped indexing my outlook emails. The service is still running. I run an update with the Google updater. But there is no change. Any search I run will only return emails going back from about a month ago.

What should I do to get it indexing again?

share|improve this question
    
What version are you using (both outlook & google desktop) ? –  John T Sep 22 '09 at 16:38
    
The Google desktop service is "Google Desktop Manager 5.8.811.4345" I'm using Outlook 2007 –  Ron Harlev Sep 22 '09 at 16:43
    
I get this too. I assumed Google Desktop simply filled up the amount of emails/files it can index and I switched to Xobni to email searching instead. –  Matthew Lock Oct 29 '09 at 9:23
2  
Google says to rebuild your index from scratch: desktop.google.com/support/bin/answer.py?hl=en&answer=13837 Some people have solved it by deleting some malformed emails that might have tripped up the indexer: groups.google.com/group/google-desktop_something-broken/msg/… –  Miss Cellanie Nov 21 '09 at 16:50
1  
You know Google Desktop is discontinued? Maybe you should check if windows search (available in microsoft update) fits your needings, too - you will get more troubles with Google Desktop over time. –  Jens Erat Oct 20 '11 at 17:21

3 Answers 3

Istead of google desktop I suggest that you can use Outlook 2007 Instant Search which has email indexing.

http://office.microsoft.com/en-us/outlook-help/find-a-message-or-item-by-using-instant-search-HA001230585.aspx

Also Google Desktop is discontinued so you cant download it from google and its no longer supported nor updated. You can only grab old version from 3rd party webistes.

share|improve this answer

Following-up @Miss Cellanie's comments, the rebuild index process is one I have had to use before.


If Google Desktop is no longer indexing new content or files past a certain date, make sure that indexing's still enabled. Here's how:

  1. Click the Desktop icon in your system tray.
  2. Select Options.
  3. Click the Desktop Search tab. If you're using an older version of Google Desktop, click Local Indexing.
  4. Select the 'Enable content indexing for new items' checkbox. For older versions of Google Desktop, deselect the checkbox next to 'Disable Indexing.'
  5. Make sure all relevant file types are selected in the 'Search Types' section.
  6. Click the Save Preferences button.

If you've correctly set your preferences and the problem persists, you may need to re-build your Google Desktop index from scratch to resolve the issue. Here's how:

  1. Uninstall Google Desktop and completely erase your old index.
  2. Click the Start menu on the computer taskbar.
  3. Select Programs.
  4. Select Google Desktop.
  5. Select Uninstall Google Desktop.
  6. Select the 'Remove completely for all users' option.
  7. Click the Yes button in the confirmation window.
  8. Deselect the 'Keep indexes in case I want to install Google Desktop again later' option.
  9. Click the Uninstall button.

    Make sure to uncheck 'Keep indexes in case I want to install Google Desktop again later' when uninstalling to completely erase your old index.

  10. Restart your computer.

  11. Reinstall the latest version of Desktop from http://desktop.google.com. After reinstalling, Desktop should correctly index your computer's content.
share|improve this answer

goto Options -> Select the "Desktop Search" tab, Uncheck the box next to "Enable content indexing for new items."...it worked like a charm to me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.