Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm following a Cocos2d tutorial and according to it, I have to send a command to a terminal to get it to downloads templates on Xcode or something. This is what it wants me to do:

After you pull down the code, you’ll want to install the useful project templates. Open up a Terminal window to the directory you downloaded Cocos2D to, and enter the following command:

./ -f -u

I tried putting that command in but it said "no such file or directory". What do I do?

By the way, my Cocos2d is downloaded in my downloads folder

EDIT: I figured it out. I had to use cd Downloads to get to my downloads, then I had to go to one more folder. After putting the above command in, it worked.

share|improve this question

migrated from Jul 22 '12 at 15:31

This question came from our site for professional and enthusiast programmers.

up vote 0 down vote accepted
  • Type Cmd + Space to open Spotlight
  • Search for "Terminal" and open it
  • Type cd ~/Downloads/ This Changes Directory to your downloads folder
  • Type ./ -f -u to install the templates.

This should have installed the Xcode templates. Restart XCode and attempt to make a new project, you should have cocos2d options.

share|improve this answer

The easiest way to get to a particular directory in the Terminal is to do the following:

  1. In the Finder navigate to the just above the directory you want to go to.
  2. Drag the directory you want to go to onto the Terminal application icon. A Terminal window will open with you already in the directory you dragged.

From there you just need to follow the directions and type the following in the new Terminal window:

./ -f -u
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .