Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to config archlinux to use my wireless network adapter. It's quite troublesome. From what I've gathered, it's an atheros network adapter, using the ath5k driver/module...

I can't get it to work; any ideas? Here's some of the output from my tinkering:

# lspci | grep -i net
00:0a.0 Ethernet controller: nVidia corporation MCP67 Ethernet (reva2)
03:00.0 Ethernet controller: atheros communications inc. AR5001 Wireless Network Adapter (rev01)

# lsusb
...
Bus 004 Device 003: ID 03f0:17d Hewlett Packard Wireless (Bluetooth + WLAN Interface [Integrated Module]

# ping -c 3 www.google.com
ping: unknown host www.google.com

#ping -c 3 8.8.8.8 
ping: network is unreachable

# lspci -v
03:00.0 Ethernet controller: atheros communications inc. AR5001 Wireless Network Adapter (rev01)
    ...
Kernel driver in use: ath5k
Kernel modules: ath5k

# dmesg |grep ath5k
registered as phy0
registered led device
ath5k: atheros chip found
PCI INT A disabled
registered led device
registered as phy1

# ip addr | sed '/^[0-9]/!d;s/: <.*$//'

1: lo
2: eth1
3: eth0

# ip link set <interface> up/down
RNETLINK answers: Operation not possible due to RF-kill

Also, is there a way to dump text from command-line to a text file so i can just copy pasta? Sorry, first time using a linux distro...

EDIT: So I just tried this:

I actually just did this twice. (I can't tell which setting is on/off for my wireless adapter. The lights are blue all the time now.)

#rfkill list
0: hp-wifi: wireless lan
    softblocked: no
    hardblocked :yes
1: hp-bluetooth: bluetooth
    softblocked: no
    hardblocked :yes
3: phy1: wireless lan
    softblocked: no
    hardblocked :yes
#rfkill list
0: hp-wifi: wireless lan
    softblocked: no
    hardblocked :no
1: hp-bluetooth: bluetooth
    softblocked: no
    hardblocked no
3: phy1: wireless lan
    softblocked: no
    hardblocked :yes
7: hci0: bluetooh
    0: hp-wifi: wireless lan
    softblocked: no
    hardblocked :no

I've dug around some other articles and it seems like ath5k is supposed to be preferable to madwifi, so should i be using madwifi? I'm 99% sure I disabled the hardblock (by turning it ON) but, as shown above, phy1 wireless lan is STILL hardblocked. What gives? Maybe I've made some more fundamental error in a basic config file?

EDIT: I've fixed the hardblock. I've tried pinging www.google.com, but to no avail. I get:

ping: unknown host www.google.com

In the arch wiki:

Edit /etc/hosts and add the same HOSTNAME you entered in /etc/rc.conf: 127.0.0.1 archlinux.domain.org localhost.localdomain localhost archlinux

To my understanding, hostname is just a user-specified and based on preference(?)

My /etc/rc.conf:

HOSTNAME="gestalt"

My /etc/hosts:

127.0.0.1 localhost.localdomain localhost gestalt

but should it be the following?

120.0.0.1 localhost.domain.org localhost.localdomain localhost gestalt

share|improve this question
    
How did you "fix the hardblock"? Does rfkill list now show the interface as not hardblocked or softblocked? –  BenjiWiebe 16 hours ago
add comment

2 Answers

RFkill is a Linux subsystem for turning on/off radio devices. "Operation not possible due to RF-kill" means RFkill was used to disable the wireless card.

Use rfkill list to check the wireless status:

$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

There are two levels of blocking – "soft block" is software-triggered (such as by clicking "Disable Wireless" in GNOME), while "hard block" is enabled using a hardware switch or a firmware setting.

If the list only shows your WLAN card being soft-blocked, use rfkill unblock <number>.

If the list shows a hard block, however, you cannot change it from within the OS – look for a "WiFi" keyboard button, an option in the BIOS/UEFI setup screen, or a physical on/off switch.

(Most laptops have Fn+something configured to turn off the wireless card, but it's not always the same – in some laptops it enables a hard-block, in others it's a soft-block.)

share|improve this answer
    
Edit: ok so I can't post code here? –  GrinReaper Jul 22 '12 at 23:21
    
*Posted results of rfkill list in OP. Does the fact that the WLAN+Bluetooth is integrated have something to do with my problem? o-o –  GrinReaper Jul 22 '12 at 23:54
add comment

I have archlinux and i use the same module for my wireless card. You should remove the module. Using

rmmod ath5k

And next press the button to turn on your wireless card, once did that insert the module again:

modprobe ath5k

This always works fine for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.