Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On the same machine I am using Win 7 and Debian Linux (KDE). I have issues with the timezone settings. Both systems are set to London time, but the clock in Windows (before it gets adjusted over the Internet) shows one hour behind. How can I configure this in such a way that both systems agree on the system time?

share|improve this question
add comment

2 Answers

Probably Linux is configured to use hardware clock as UTC, whereas Windows wants the hardware clock to be set to the "wall time". Since you're dual booting, you'll need to configure Linux to not use UTC for the hardware clock.

Some linux distributions use

/etc/sysconfig/clock

whereas Ubuntu and Debian use

/etc/default/rcS

In this file change UTC=true to UTC=false

You can use the command

hwclock --systohc --localtime

to set the hardware clock from within Linux.

share|improve this answer
    
I can't find file /etc/rcS on my Debian system. There is /etc/rcS.d, but it is a directory with soft links to start-up scripts... –  Grzenio Aug 29 '12 at 15:10
    
It's /etc/default/rcS on my Ubuntu systems. I've updated the original answer to reflect that. –  Colin 't Hart Sep 5 '12 at 8:57
    
I actually found in the man page for rcS the following The UTC setting is replaced by the UTC or LOCAL setting in /etc/adjtime, and should have been migrated automatically. See hwclock(5) and hwclock(8) for further details on configuring the system clock. I will report further after investigation. –  Grzenio Sep 5 '12 at 14:17
    
I don't see this in the man page for rcS on Ubuntu 12.04.1 LTS (the current and latest version). –  Colin 't Hart Sep 5 '12 at 14:53
    
Maybe Debian is different... –  Grzenio Sep 6 '12 at 9:43
add comment

Is daylight savings turned on in Windows?

For dual boot systems, you could take the time from the BIOS clock. This would solve your issue.

share|improve this answer
    
I think so. Where can I double check? –  Grzenio Jul 23 '12 at 12:23
    
See this link: superuser.com/questions/35544/… –  Dave Rook Jul 23 '12 at 12:34
    
Yes, I confirm that the daylight saving is turned on in Windows. –  Grzenio Jul 23 '12 at 13:18
    
and is it also for the Linux OS? –  Dave Rook Jul 23 '12 at 13:19
    
Actually, there is no specific option in KDE (after logging into Linux). However, the time did change correctly on the day when DST started. –  Grzenio Jul 23 '12 at 13:39
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.