Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

enter image description here

As you can see in the first image, I have selected always open with notepad++ program. But, the problem is that the all the php files are opening with notepad++ program but the icons doesn't change. The php script file takes the previous program icon i.e. Dreamweaver, which I previously used for opening my php script files.

enter image description here

This happens with other file types also i.e. audio or video file types.

I want to know- how can I resolve this problem.

My system OS - Win XP sp3; Antivirus - KIS 2012; and also malwarebytes 1.62.

share|improve this question
1  
Why the hell this question is closed and called duplicate. The one who told my question is duplicate please post an appropriate answer for my problem. Then only I will agree if it is duplicate or not!!! –  FrozenKing Jul 23 '12 at 15:27
1  
I agree @FrozenKing that this should not have been closed as a duplicate, but swearing at users and making harsh demands - especially when you're a relatively new user - is not a good way to make people see your side of the issue. –  nhinkle Jul 23 '12 at 20:09
1  
@nhinkel I agree with your terms but I needed this problem to be solved. And when my question was considered duplicate without, pointing to some appropriate questions which was answered previously; I was disappointed. I searched superuser and google but none of them provided any help to me. So I had to do something to get a solution to my problem. –  FrozenKing Jul 25 '12 at 10:32
    
same problem with my notepad++ on Win-7. @FrozenKing i guess this problem is with Notepad++ rather than windows. the below answers are not helping. –  kmonsoor Mar 11 '13 at 7:48
add comment

3 Answers 3

up vote 0 down vote accepted

i have found the solution. it works on my Windows 7. I guess, it will also work on Win XP. i found the clue here in NPP forum wiki.

  1. Download FileTypesMan (freeware) and install
  2. for .txt filetype, press F2 or select "Edit selected file type" from tight-click-menu, the properties as the below image:

    Edit selected file type

  3. in the detail dialog box, select ur chosen icon. It's done.

    choose icon

  4. Now check it where you have any text (or edited file-type) file if the selected icon is there or not.

    bingo

share|improve this answer
add comment

Is it a problem? if it opens in correct program, who cares about the icon?

Restarting the computer will solve the problem for most people

Nevertheless, try this: Recreate the Icon-Cache by changing icon size:

  • Open Control Panel and double click Display-applet
  • Select Appearance-tab and in Item-dropdown select Icon
  • Increase Size and press Apply-button
  • Decrease Size back to old value and press Apply-button
  • Press Ok-button
share|improve this answer
    
Restarting doesn't solve my problem. Actually I am posting this question because I want to know, why this unusual thing is happening. This might be a virus or some system file corruption has occurred. I just want to know how to make my pc normal again. –  FrozenKing Jul 23 '12 at 13:55
    
@FrozenKing did you try resetting icon-cache? –  Sandro Dzneladze Jul 23 '12 at 13:58
    
@FrozenKing try procedure outlined here: winability.com/repair-windows-desktop-icon-cache I don't think it is a virus or system file corruption. More like xp quirck. –  Sandro Dzneladze Jul 23 '12 at 14:00
    
@Sandro is there any manual way of doing this? –  FrozenKing Jul 23 '12 at 14:05
1  
@FrozenKing manual or automatic? did you try it any of the two tricks? –  Sandro Dzneladze Jul 23 '12 at 14:23
show 2 more comments

Click Start, and then click Control Panel.
Click Folder Options.
Click File Types tab in Folder Options window and the full file types and their association will be listed.
Click New and type the File Extension in the box and then click Advanced.
Choose an association for the file type.
Click OK and then Click Close.
Open the file again.

(From http://support.microsoft.com/kb/307859)

From here, you should be able to find the file type and either associate or de-associate programs.

share|improve this answer
    
Problem still persist. –  FrozenKing Jul 23 '12 at 15:24
    
So, PHP was a file type in the list? –  Dave Rook Jul 23 '12 at 15:33
    
yes, there is already listed php file types opening with notepad++ but change is not happening in the icon? Is there is a corrupt file in my system OS –  FrozenKing Jul 23 '12 at 16:12
    
Not sure - let's try third party software (which I found after a Google so I can't promise it will work etc): winhelponline.com/blog/unassociate-file-types-windows-7-vista –  Dave Rook Jul 24 '12 at 8:00
    
Or, this may be a dreamweaver thing! Try: the links on the Adobe site: helpx.adobe.com/dreamweaver/kb/… –  Dave Rook Jul 24 '12 at 8:02
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.