Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed vsftpd on my Turnkey Linux virtual machine and I can connect to it, a prompt is displayed asking me for my password.

What is the default username/password for vsftpd?

I also enabled anonymous usage in etc/vsftpd.conf but it's still asking me to enter a password when I try to login using "anonymous" as my username.

Thanks!

share|improve this question
    
Did you also turn on the no_anon_password=YES setting in vsftpd.conf? –  ÃŁŁǫǛȉЖΦΤїҪ Jul 23 '12 at 16:13
add comment

1 Answer 1

Make sure you have anonymous enable in vsftpd.conf

anonymous_enable=YES

If this is enable & anonymous is not working, Check if selinux is not blocking it.

# setenforce 0

There can be numerous issues with vsftp & selinux in regard of home directory, ftp connecting to database for authentication.

Try to login with ftp as username & password.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.