Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am struggling to setup my home network. I have the following setup, also shown in the diagram below (sorry for the MS Word screenshot!):

  • My landlord has an ADSL connection, established by Router 1, IP address 192.168.0.1
  • Router 1 runs a DHCP server.
  • I connected my own Router 2 to my landlord's Router 1 via an ethernet cable running from one LAN port to another (not using any WAN port), and I turned off the DHCP server on Router 2. I manually assigned the IP address 192.168.0.150 to Router 2.
  • My desktop PC connects to Router 2 via ethernet cable and gets an IP address automatically from the DHCP server on Router 1. This connection works perfectly and I can access the internet from my desktop PC without any issues whatsoever.
  • The WiFi from Router 1 is out of range in my room, so I want to connect my laptop to the Wifi on Router 2. I have my laptop set up to obtain an IP address and DNS address automatically. After I connect, the Laptop's IP address is 192.168.0.106, the Default Gateway is 192.168.0.1 and the DNS server is 192.168.0.1 (all this from ipconfig /all).

The internet on my Laptop, connected via the Wifi, fails to work. Any attempt to access a webpage results in "DNS failed to respond" or "www.somesite.foo took too long to respond". At times a page starts to load, but fails after about 5% and times out.

Attempts to connect to either of the routers' management pages at 192.168.0.1 or 192.168.0.150 also sometimes succeeds but mostly just times out. When it "succeeds" it is incredibly slow. I can ping both servers, but I cannot ping the desktop PC connected to Router 2.

The laptop is right by the router and the signal strength is full.

I don't need to connect to any of my landlord's PCs - I just need to use his ADSL connection.

If there are any more details I can provide, please ask me in the comments and I will provide them as updates as soon as I can.

Thanks

enter image description here

UPDATE 1

The setup is similiar to the one in this question

UPDATE 2

My landlord's router (Router 1) is some FRITZ!Box model.

My router (Router 2) is a TP-LINK TL-MR3420

UPDATE 3

My laptop's WiFi adapter is an Atheros AR9285.

I have established that my wife's laptop can successfully connect to the router via WiFi (she usually connects via ethernet cable). Her laptop's adapter is an Atheros AR5B93

share|improve this question
    
We could probably help more with the make and model of the router. –  allquixotic Jul 23 '12 at 17:44
    
Thanks @allquixotic, updated with router models. –  Pieter Müller Jul 23 '12 at 17:55

2 Answers 2

up vote 5 down vote accepted

This sounds more like a "the wifi connection sucks" issue than a "there's no connection" issue, especially since you said you can sometimes get pages to start loading but it's very slow.

Possible problems:

  1. Just a hard incompatibility between your laptop's wifi adapter and Router 2's wifi settings or chipset. This can either be something physical that's impossible to resolve without hardware hacking, or it can be something you can fix by tweaking software, most likely config settings in the router's firmware... but without knowing either the router or the adapter's make/model it's hard to be more specific.

  2. Too much wireless traffic in your area. Is this an apartment? Apartments are notorious for having too much wifi crosstalk, so even devices sitting right next to eachother can't communicate. Have you ever tried to have a conversation with someone during a heavy metal concert? Changing the wireless channel of your router can sometimes help if you have a nearby access point(s) communicating on the same channel as yours.

  3. Cordless phone, bluetooth, or microwave oven interference. More likely to exist if you're on the noiser 2.4 GHz band rather than the relatively less-used 5 GHz band, but still, it's a possibility.

  4. Polarization. Wireless signals are "polarized" in the same way sunglasses are, to block light waves in a certain direction.

An intuitive understanding of polarization: take a long piece of Lasagna pasta. It's a wavy piece of material. Now put the pasta into a cast iron mold and let the mold set to a solid. Remove the pasta. Now you have a mold which is shaped like the pasta, but it's a hole where the pasta could go. Now, line up the pasta with the mold and insert it right in. It should go in although you may get resistance due to the wavy nature of it (ignore that part, bad example ;)). Now, rotate the mold by 90 degrees. Now you can't insert the pasta in at all, it just bumps up against the frame of the mold! Because the dimensions don't match up. You're trying to put the width in along the original height axis and vice versa.

To test for polarization, just rotate your laptop slowly in place while measuring performance (ping command, etc). If it suddenly picks up, congrats you have polarization.

  1. For the ultra-long answer, see Tom's Hardware
share|improve this answer
    
Thanks, as an engineer, I really enjoyed your pasta analogy! :-) I think you might be correct about incompatability though - I tried and my wife's laptop can connect while mine can't (see update to original post). I previously used the router at a different location, and it worked fine with my laptop, but I have since upgraded the firmware on the router. Any suggestions? –  Pieter Müller Jul 23 '12 at 18:10
    
Hmm, my wife's wifi also comes and goes. Maybe my router is just busted. –  Pieter Müller Jul 23 '12 at 18:17
2  
Bah! Why is the solution always SO SIMPLE once you find it!? You were right about interference - My router was on channel 1, the same as my landlord's router. I changed it to channel 11 and now it works perfectly. Thanks for your efforts! You might want to update your answer's point 2 and just mention changing the channel, for the benefit of future readers. –  Pieter Müller Jul 23 '12 at 18:25

I don't think the router should be resolving DNS requests. Point your DNS to 8.8.8.8 (Google's DNS servers), either in your router's DNS settings or your laptop's.

Try it in your laptop real quick first. I assume you know where but if not...

Open up network connections, right click your wireless adapter, scroll down to IPV4 protocol, right click and select properties. enter image description here

share|improve this answer
    
Thanks for the screenshots - I didn't know about google's DNS servers, and will remember it for future challenges. My problem ended up to be plain old channel interference and seems to be fixed now. –  Pieter Müller Jul 23 '12 at 18:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.