Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In windows 7 when browsing through the alt+tab thumbnails, lingering on one thumbnail for a second will engage the Aero-Peek effect causing every window to be transparent except for the chosen window.
This effect is slightly delayed before starting for the first time of each alt+tab “session”, and afterwards will be applied quicker as you browse through the thumbnails.

Is there a way to change the value of that initial delay?
And maybe even that of the subsequent faster delays?

share|improve this question
See also… – swref May 26 '13 at 10:11
up vote 32 down vote accepted

Okay I've found the answer. Someone was kind to share some knowledge on my post at the Microsoft forum:

Open Registry Editor and create the following registry key:


In that key, create the following DWORD value: LivePreview_ms and set it to the delay (in milliseconds) of the first live preview.

Restart Explorer to see the changes.

Other Aero-peek related registry entries that I've found on the net are:

  • DesktopLivePreviewHoverTime
  • ThumbnailLivePreviewHoverTime
  • ExtendedUIHoverTime

These control the delay of other components of Aero-peek.

share|improve this answer
Found a solution!, it works. – gnz Dec 20 '09 at 10:06
This doesn't work for me. :( – Derek Morrison Feb 24 '12 at 22:05
In Windows 7, simply turning off "Enable Aero Peek" in the "System" / "Advanced System Settings" / "Performance Options" dialog works well, and doesn't require you to restart Explorer. – Glen Little Feb 22 '14 at 16:24
I must warn this doesn't work with zero - that disables it totally. I set mine to 1ms. Sure helps me figure out which terminal window I'm switching into. – kavisiegel Jul 15 '14 at 4:32

This free product might solve your problem : Desktop Peek Tweak. I quote:

This is a quick utility to adjust Desktop Peek delay time when you hover the mouse over the appropriate button on the desktop


share|improve this answer
+1 That sure looks like the solution – Ivo Flipse Sep 22 '09 at 19:26
No, it only changes the delay of the "show desktop" button (as advertised), but not of the alt+tab, thanks anyway. – Eran Sep 22 '09 at 19:33
Do you mean there are multiple Aero-Peek effects with multiple delays? – harrymc Sep 22 '09 at 20:30
It would seem so. – Eran Sep 23 '09 at 3:19
Bravo, Microsoft. – harrymc Sep 23 '09 at 6:33

You can turn off via windows config menus:

Windows 7 ALT-TAB - How to turn off previewing the window

share|improve this answer
Awesome - thanks! – Derek Morrison Feb 24 '12 at 22:09

This shows multiple methods on how to do it:

It provides a zip with a .reg file to modify the registry and also a manual method of setting it in the registry, but I suspect it does exactly the same thing as Desktop Peek Tweak.

share|improve this answer
No, like the other answer, it only changes the delay for the show desktop button, but doesn't affect the delay in the alt+tab. – Eran Sep 23 '09 at 3:19
I was at work so I couldn't test it, I'm actually keen to get what you're asking for as well. – Michael Galos Sep 23 '09 at 5:23

if you press ALT + CTRL + tab you can freeze the dialog up till you click out or select a window.

share|improve this answer
This isn't really relevant to what is asked. But moreover a long time ago this [question] was already answered and the accepted answer is good, there is no need to add answers such as yours (no offence, I hope). – Eran Apr 29 '11 at 17:03
its just a way to increase the time the window will stay up...not the exact answer and none taken. – mjrider Apr 29 '11 at 17:07
Interesting, I never knew this before! I agree with @Xenorose that the answer doesn't quite fit the question, but that is a good tip. – nhinkle Apr 29 '11 at 18:17
it works the same way with windows key + ctrl + tab too – mjrider Apr 29 '11 at 19:31
@Xenorose - Although the question is answered for the original party, these answers are very helpful for others visiting this page. Even if the question was old - the answers are new - topic resurrection is despised amongst message board users because it brings the post back to the top of the activity list - but it's a genuinely good practice on sites like SO and SU to provide updates as the information changes or to fill in gaps in the overall picture. It's ok to ease up on policing this behavior. – Marcus Pope Jun 1 '11 at 16:49

Simple solution:

;; Disable Aero-ALT-TAB, use Old-XP-Style.

;; Set how many rows are shown in task switcher (ALT-TAB).  Default seems to be 3x7.
[HKEY_CURRENT_USER\Control Panel\Desktop]

These settings bring back the old XP-Syle for the task switcher. Used them for few years now on many Windows 7 installations.

share|improve this answer
Don't understand the downvote. This worked very nicely on at least a dozen Windows 7 installations. – Andreas Spindler Oct 29 '14 at 16:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .