Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have created a dev environment of my website... using VirtualBox... and now I need to make it accessible outside of my home office network. I am using Virtualbox 4.1.18 installed on a Win7 desktop host. The virtual machine is running CentOS 5.6. My home office has a static ip. I am using a Linksys router e4200. The virtual machine is setup to use a bridged adapter. My virtual machine can access the web. My host pc can ping the virtual machine successfully. Other PC's on my home network can successfully ping my host pc and the virtual machine. I have given the virtual machine its own static IP on my network as well.

How do I test if others outside my home office network can see this dev server? Which ip address will point to the dev server in this scenario?

What should I do next so that third party developers can access this server via ftp and/or ssh?

share|improve this question

migrated from stackoverflow.com Jul 23 '12 at 22:20

This question came from our site for professional and enthusiast programmers.

    
    
Thanks Oliver but no... none of those links helped. –  UndeadPup Jul 24 '12 at 3:17

2 Answers 2

You need to go to your Router and set the virtual server to have the static IP; not your virtual host.

Alternatively, you could forward ports using Virtualbox (not sure how easy that is), but it's more work than just giving your CentOS box the static IP. The router doesn't really care that it's a virtual server, because you're using bridged networking.

The IP you would use, afterwards, is the public IP of your home network.

Good luck

share|improve this answer
    
Won't setting the VM to have the static IP cause other machines on his network to lose connectivity? –  Tanner Jul 23 '12 at 22:34
1  
I don't think so, judging from my experience with consumer-grade Cisco routers. –  David Jul 23 '12 at 22:36
    
Try forwarding ports such as 80 (HTTP) and 22 (SSH) and others to your VM's private IP address, so only ports you need are passed to the VM. –  David Jul 23 '12 at 22:36
    
I did that. Using Filezilla I am unable to FTP successfully to the virtual server using the home office IP and port 21 (which is the port I set to forward). –  UndeadPup Jul 23 '12 at 23:19
    
On the CentOS server, do "service iptables stop" as root to see if it's your firewall blocking it. –  David Jul 23 '12 at 23:28

You will need to forward the ports to your virtual machine. If it's set to bridged, it should be sitting on your network just like any other physical machine would. From that point it's a matter of getting your router to direct incoming FTP and SSH traffic to your server using port forwarding.

share|improve this answer
    
When I turn on Port Forwarding, using the common ports (80,21,22), my virtual server loses internet connectivity. While troubleshooting I performed the following actions: 1. On the virtual server I turned off static ip - still no internet 2. In my physical router I released the DHCP ip reservation - still no internet 3. Disabled the port forwarding - internet access back for virtual server. –  UndeadPup Jul 24 '12 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.