Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an older application that crashes on launch on a Windows 7-64 bit machine. The root cause, according to the internets, is apparently I have too much memory and the app has some bug when it sees more than 4 (3.5) GB of RAM.

Can I launch the exe with command line arguments telling the app I have less memory? Or create a launcher process with restricted memory? Anything from command line, batch scripts, to win32 code is fair game for me.

I realize it's a long shot, but I welcome any suggestions, thanks.

share|improve this question
8  
Have you tried a virtual machine? – soandos Jul 23 '12 at 22:58
    
Yeah I thought about using Windows XP Mode but I am not on Professional. I could do a virtual PC and install a full Win 7 virtual, but I am holding that as my backup plan. Thanks for the comment though! – blu Jul 23 '12 at 23:01
3  
Right-click on the shortcut, select Properties, then Compatability. Check Run this program in compatibility mode and select the OS the application was designed to run under. – David Schwartz Jul 23 '12 at 23:02
    
@David A good idea which I tried before I posted. That causes an external file pathing issue with the app. Thanks though! – blu Jul 23 '12 at 23:03
    
@David I finangled some settings with a related app, and in combination with running in compatibility mode I got this to work. If you want to post your comment as an answer I will mark as accepted, thanks. – blu Jul 23 '12 at 23:18
up vote 9 down vote accepted

Right-click on the shortcut, select Properties, then Compatability. Check Run this program in compatibility mode and select the OS the application was designed to run under.

share|improve this answer

For a tremendous overkill waste of resources, run windows inside a virtual machine and control the amount of RAM using the VM. Again, this is using overkill to fix this. The only reason I would do this is to not have to make any changes on my computer AND if I expected the code writer to have a fix AND if the easy answer (David Schwartz answer) didn't work.

share|improve this answer

If setting compatibility modes do not work then you can try:

  • Taking out a stick of RAM so that you have less RAM

    Do note that for dual channel tri channel RAM, you need multiples of 2 or 3 sticks of RAM respectively to work.

  • If that does not work, you can try running the program in a VM. There are other VM options than MS VM and XP mode. A popular free VM software is VirtualBox

  • If you do not have a copy of a compatible OS then you can also try installing Linux on a VM, or install 32 bit Linux on your machine, and run that program under Wine

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .