Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have TB connecting to the IMAP interface of an exchange server. I also have my mail synchronised to the machine for off-line use.

When I move a message from the inbox to an archive folder, the message moves as expected under TB, but when I look at the actual mail server directly using another client, the message still exists in the inbox.

The only way I know of forcing a flush of the TB state to the IMAP server is to shutdown TB, which is not a fantastic solution. I have IDLE enabled, but this seems to only provide sync from the server to client for changes at the server (no client to server for changes to the IMAP message state).

Is there any obscure setting that I can twiddle to make the state flush to the server immediately?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You can set the mail.imap.expunge_option to enable this behaviour. Details of the settings can be found in the following link:

http://kb.mozillazine.org/Deleting_messages_in_IMAP_accounts#Misc

The option can be modified in Edit -> Preferences -> Advanced -> Config Editor

share|improve this answer
    
Cool, that seems to work. –  atikat Jul 24 '12 at 2:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.