Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Until a few days ago, tmux was working fine.

Suddenly, I don't know what my colleague did, but the shortcuts stopped working.

We're both using tmux on a remote server (two different sessions), but no session works now.

I mean, we can attach them (tmux a -t name works), but then, the shortcut doesn't work.

If I do Ctrl + a, d, it just writes d to the terminal. I tried with the original shortcut (Ctrl + b) but no change.

My tmux.conf is clearly taken into account, since if I do tmux new -s someName, I get all the status bar and stuff. The initialization shortcut doesn't work however.

Any idea of what could cause this?

share|improve this question
    
What does tmux list-keys show? –  cYrus Jul 24 '12 at 9:29
    
@cYrus The normal list of shortcuts available. What's not working in tmux is the "Enable tmux commands" shortcut, whatever it's called. Do you want a copy paste of tmux list-keys? –  Florian Margaine Jul 24 '12 at 9:31
    
If that list contains the shortcuts that you're expecting that's ok. Just check for the usual set-option -g prefix C-a in your configuration file. –  cYrus Jul 24 '12 at 9:41
    
I checked it, and it's ok. This conf worked fine until a few days ago... –  Florian Margaine Jul 24 '12 at 10:14
    
@cYrus If you're interested, I added an answer to add the debugging commands I used :-) –  Florian Margaine Jul 24 '12 at 12:08
add comment

1 Answer

up vote 4 down vote accepted

Thanks to @ccxCZ on #tmux@freenode.net, I could find what was the problem.

Using the following:

tmux show-options -g | grep prefix

Showed me that the prefix was:

prefix `

Testing it, it was indeed this. I don't know how it turned out this way.

Since my tmux.conf was right, I just had to do:

tmux source /etc/tmux.conf

And the prefix was set back to the right way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.