Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I did a system update yesterday and there was only one, which was for my Epson printer. Today on reboot, I get a blue screen with a revolving disk. I managed to get my installation disk in and pressed the C button but nothing. I rebooted and held the mouse key but the DVD does not want to come out. I have a windows wireless keyboard and I have held down every key possible but still no luck.

I have had this Mac Mini with Snow Leopard 10.6.8 for about 7 years now but I think it has finally had it. Any ideas please before i buy a new pc?

share|improve this question
    
Try using a keyboard with a physical connection. This eliminates any possibility that it is a wireless connection issue. –  Everett Jul 24 '12 at 16:29

1 Answer 1

From CNet:

The likely cause is a corrupt system file which can be cured by booting the mini from the OS X installation disk, or the Recovery Disk that came with the mini, and running an Archive and Install of the system. Prior to doing that, and after you have booted the machine from an external disk, run the disk utility that you will find on the OS X installation disk. If all is well, proceed with the Archive and Install.

Archive and Install will preserve all your data while replacing the system.

If the internal disk drive does not work you can try booting from an external one.

share|improve this answer
    
i am waiting for my wife to come in as she might know where my wired keyboard is,as i say my installation disk is in the mac and i have tried holding the c button so it boots from it but no luck,i bought an external dvd writer for the mac a few weeks ago so if i can get the installation disk out i could try that,i have held the mouse button on reboot to try to get the dvd out but no luck ? –  John Penrose Jul 24 '12 at 16:36
    
When you turn the computer off and back on, do you see a grey screen come up with an Apple logo? If you do, we can continue. If not, the answer here MAY help: superuser.com/questions/23810/mac-mini-wont-boot-and-wont-fix –  Everett Jul 24 '12 at 16:39
    
CNet mentioned an eternal drive and i have just found a copy of my installation disk,i went to utility and i am repairing permissions at the moment and then i will do an archive and install,i will post after completion –  John Penrose Jul 24 '12 at 16:50
    
i did a disk repair and i am currently re-installing my system. –  John Penrose Jul 24 '12 at 18:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.