Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a program that crashed, its GUI is frozen, and I would like to kill it.

However there is no trace of it among the current processes.

I tried both top and ps -A, but I got nothing.

The program is NetBeans 7.2. Could the reason be that it is a Java program, and what I need to kill is Java itself?

Thank you!

System: OpenSuse 11.4

share|improve this question
up vote 5 down vote accepted

Yes, it's java.

I'd try:

ps auwwwx | grep '[j]ava' 

Then see which is the netbeans one. You could also try running in a terminal:

xkill

and click on the NetBeans window to kill it

share|improve this answer
1  
I got two processes from ps. I could kill just one of them, the other seemed to be immortal. With xkill I solved the problem. Thank you! – Pietro Jul 25 '12 at 8:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .