Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm new to VirtualBox. Someone helped me set up a Fedora 16 installation on VirtualBox.

The problem is that I can't save anything. I first tried setting up LAMP and installed Apache and MySQL from the command line and it worked. It said "completed", and when I typed

rpm -q mysql 

it found the package.

But when I rebooted the machine (by clicking the restart button INSIDE Fedora, not on the VirtualBox screen) all the changes were lost. The same happened when I tried saving a file to the desktop.

What settings need to be changed to fix this issue?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There could be something wrong with your install. Make sure that you're not booting to a 'LiveCD' and that Fedora is in fact installed on to the VHD. It could be that the CD is still 'in' the VM, check to make sure that the .iso used to install Fedora has be unmounted. enter image description here

When I first started using virtualization, I blamed everything on VirtualBox. Now I've found that it's best to begin your troubleshooting from within. Treat it like a 'real' machine. Did you take the CD out before rebooting? Is Fedora installed properly? Asking the easy questions first would've saved me a lot of time on the VirtualBox forums hunting for things I had screwed up myself.

If the disc won't unmount, it is probably in use by the system. Shut down the machine and then unmount the .iso.

share|improve this answer
I don't have real cd, I just have a iso image on my computer. So I can't take a cd out before rebooting... – user1015214 Jul 24 '12 at 21:06
And which settings exactly am I supposed to be looking at to see if Fedora is installed correctly? It loads up fine. The only issue I ever saw (and dismissed since I didn't know what it meant) was that Gnome 3 wasn't able to load properly. Can this be the issue somehow? – user1015214 Jul 24 '12 at 21:11
Updated with screen shot of what I'm talking about. – Tanner Faulkner Jul 24 '12 at 21:12
TBH, I'm not too familiar with Fedora. But I did run in to an 'installation' of Ubuntu once that was actually just a LiveCD on a VHD. – Tanner Faulkner Jul 24 '12 at 21:13
I can't see your screenshot, its just an empty box. – user1015214 Jul 24 '12 at 21:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.