Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought an OCZ 120gb Agility 3 SSD for my Dell XPS 15 (L501X). I installed a fresh copy of Windows 7 Professional and had no issues for about a day or two.

After doing some Windows updates, installing some programs and having a regular session of using the computer, I rebooted to finish the updates. On booting, I had a black screen after login. I checked the processes (CTRL+SHIFT+ESC to the Task Manager) and explorer.exe wasn't running, tried to run it and it shut itself back down. At this point I'm worried. I reboot again, same result. I pull out my USB drive I used to install Windows 7, try a repair, but the repair tool said it couldn't find an OS. What? I reboot again, but this time, I get a missing MBR error.

I rebooted a few more times, same result in the repair, no OS found. I was able to copy files to and from my SSD through the driver open explorer window, so the SSD is still fine. I tried swapping USB ports to see if it made a difference, and this time it did find my OS. I tried a repair, it said it worked. I restart my computer and still get the missing MBR error. I tried to boot from the USB again to try and fix it, but instead of booting the install menu, it now boots into Windows from my USB. Apparently it put the MBR on my USB drive... I'm stuck booting with my USB drive for now. I can deal with that for now since I'm using my laptop as a desktop replacement.

My future plan is to replace my DVD drive with my old HDD. I just received the drive caddy, so I'm ready to do that soon. However before I do, I want to fix this MBR problem.

This is the error I get when booting from my SSD:

enter image description here

I tried some bcdedit and bootrec related stuff described here but to no avail. I'm not sure what to try next.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Since you can boot into the system, you could probably use EasyBCD - the community edition is free for personal use or visualbcd editor to install/edit the bootloader I'm using EasyBCD more so I'll show how to use that.It should be about as simple as installing EasyBCD, selecting bcd deployment, and selecting your drive. Double check with Edit Boot Menu to make sure the drive you want is booting, and you're good.

enter image description here

share|improve this answer
    
THANK YOU. Coincidentally, I was actually running that program when I saw your answer. I just didn't really see that menu or know how to use it until you mentioned it. :) –  MaxGhost Jul 25 '12 at 1:25
    
I actually didn't realise that menu was there until i went to make a screenshot. I was assuming the backup/repair button would do the trick. This is why discrete, split up questions are good ;) –  Journeyman Geek Jul 25 '12 at 3:02
    
Yeah I understand, I was skeptical about my multipart question in the first place. Thanks so much for all your help! –  MaxGhost Jul 25 '12 at 15:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.