Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dual-boot Windows 7 64 bit/Linux 64 bit machine that uses ATI's Catalyst drivers. Sometimes I attach it to a 1080p LCD TV over HDMI. ATI is daft enough to provide a border to account for overscan.

I'm using an LCD TV. No overscan, or it looks like crap because the pixel mapping is not 1:1. How do I disable this driver "feature" in Windows? in Linux?

share|improve this question
add comment

3 Answers

I'm not 100% sure what the problem is, but if you're connecting over HMDI, then you're probably going to have overscan issues as the TV cannot give its EDID over HDMI. You will have to manually compendate for overscan in the catalyst control center overscan section. I'm assuming you know about the overscan slider in the ATI CCC?

If your problem is that when you have that slider adjusted so that the boarder doesn't display and it still looks like garbage then I'm not sure what your problem is as pixels should still be 1:1 if you have the resolution set right. 1080p is 1920x1080.

Are you using the latest drivers if all of these are above are correct?

share|improve this answer
    
I'm using the latest drivers. The problem is that the driver outputs 1920x1080 but draws the screen on a ~1700x900 rectangle inside that signal. There's a slider inside the Linux control center to control the amount of overscan adjustment but I haven't figured out how to get it to just never do that. It knows the brand of the TV so it's reading something from the HDMI cable. –  joeforker Sep 23 '09 at 0:55
1  
In Catalyst Control Center in wondows (I don't use it in Linux) you can go to the "Overscan" tab and slide it completely to the opposite side and it should eliminate overscan. It should be persistent in windows as I only had to set it once. –  MDMarra Sep 23 '09 at 1:15
    
Where is this overscan slider? I can't find it anywhere and I'm kind of losing it when searching for anything in the CCC. –  alex Oct 18 '09 at 20:23
    
It's in the HDTV section. What version of CCC are you using? –  MDMarra Oct 18 '09 at 23:09
    
I'm using 9.9 at the moment. The thing is it's not there for my TV, only for my LCD display. If I click configure for my TV, it sends me to the Welcome tab. This is not normal, right? –  alex Oct 19 '09 at 6:03
show 1 more comment

ATI Catalyst Drivers 9.10 introduced a new feature:

Underscan/Overscan settings for TV can now be applied from the ATI Catalyst ControlCenter – TV Properties Adjustments page.

Maybe could be a solution for your problem.

share|improve this answer
add comment

Sometimes Catalyst Control Center will not diplay the Overscan slider.

I have a VAIO laptop, and Sony uses its own ATI drivers, so no help from ATI's webpages. On that, I could not for the life of me find the overscan slider - whenever I chose to configure my display, it'd go directly to the Welcome Screen. This was after fiddling about with getting the stupid CCC to install in the first place (using ATI Mobility Modder).

Google searches told me, that a lot of users have this problem, not only on VAIO computers. Some have the overscan slider for a while, then it disappears, others like me never have it in the first place.

I did find a solution though:

Open regedit and go to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\

In there, there'll be some keys looking like this:

{ECA904C2-25E6-4680-9B2C-44EBC0EC9190} (with different numbers ;o)

Highlight the "Video" key on top of the tree, and do a search for "1920x1080"

You'll find some keys in subfolders named 0000, 0001, etc.

The keys will begin with DALR6 DFPXXXXxYYYYx0xFF

XXXX= Horizontal resolution YYYY= Vertical resolution FF= Display frequency

Before you continue, take a bakup of the original keys by right-clicking the {ECA904C2-25E6-4680-9B2C-44EBC0EC9190}-type key, and select "Export"

Click on the key matching the screen resolution and frequency you want to remove the borders of.

A lot of the key will consist of "00", but there'll be a few non-00 entries. Change all of these to 00.

Finally, I had two subfolders, 0000 and 0001, containing mirrors of the same keys. When I changed a key in one subfolder, it also changed in the other.

This fixed the problem for me, no need to install CCC.

Effects will take place next time you change the screen resolution.

/Fangrim

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.