Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Java browser plug-in is no longer working. When I open a page that has a Java element, Java cannot connect to the server.

After investigation, I found that Java was trying to use IPv6, while my network does not support IPv6, so Java always fails to connect.

I tried looking on Google and found that I should run Java with -Djava.net.preferIPv4Stack=true, but how can I pass this to the browser?

I use Google Chrome and Java 7 update 5.

share|improve this question
    
Why don't you disable the IPv6 protocol so Java won't have this option. –  harrymc Aug 30 '13 at 18:55
    
it is a old story, I do not know if I've disable IPv6 protocol, seems to have, I've forgotten, what I remember is I remove Java 7 and replace it with Java 6 –  nyongrand Aug 31 '13 at 9:21
1  
Disabling is easy : see this. –  harrymc Aug 31 '13 at 9:25

1 Answer 1

up vote 14 down vote accepted

Put the options in _JAVA_OPTIONS environment variable. How to do this is already described in various other posts – although they usually talk about setting PATH, but it's all the same.

For example, on Linux, put the following in your ~/.profile or ~/.bash_profile:

export _JAVA_OPTIONS="-Djava.net.preferIPv4Stack=true"
share|improve this answer
    
ok, thanks for your reply, although i use windows but your solution inspire me, thanks –  nyongrand Jul 25 '12 at 19:28
    
See for example this post for setting environment variables: superuser.com/questions/284342/… –  user2428118 Aug 30 '13 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.