Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have assembled a custom PC, and installed Linux on it. I have tried using several different SSDs of the same kind, and I keep getting the following types of random Read/Write errors:

[  310.697924] ata1: lost interrupt (Status 0x50)
[  310.697949] ata1.00: exception Emask 0x50 SAct 0x0 SErr 0x40d0802 action 0xe frozen
[  310.698036] ata1.00: SError: { RecovComm HostInt PHYRdyChg CommWake 10B8B DevExch }
[  310.698119] ata1.00: failed command: WRITE DMA
[  310.698185] ata1.00: cmd ca/00:20:18:08:8a/00:00:00:00:00/e0 tag 0 dma 16384 out
[  310.698187]          res 40/00:00:00:00:00/00:00:00:00:00/40 Emask 0x54 (ATA bus error)
[  310.698348] ata1.00: status: { DRDY }
[  310.698415] ata1.00: hard resetting link
[  311.421105] ata1.01: hard resetting link
[  311.896619] ata1.00: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[  311.896634] ata1.01: SATA link down (SStatus 0 SControl 300)
[  311.936849] ata1.00: configured for UDMA/133
[  311.936858] ata1.00: device reported invalid CHS sector 0
[  311.936866] ata1: EH complete

The same SSDs work fine on another computer. And I tried using some HDDs with the computer in question, and they work fine too. So what could be wrong? Is it the sata cables? Does sata cable quality really matter?

Also, one of my SSDs (which was brand new) was not even being detected. I tried using a different cable, and the system detects it now, but still throws these errors randomly. How can I troubleshoot my computer?


This motherboard:

This SSD:

share|improve this question

migrated from Jul 25 '12 at 12:39

This question came from our site for system and network administrators.

I would suspect the cables, definitely. – David Schwartz Jul 25 '12 at 12:53
What kind of cable would you suggest? – Richard Whitman Jul 25 '12 at 13:03
One designed for the highest speed your motherboard and SSD support. – David Schwartz Jul 25 '12 at 13:04
The ones I am using are. They are Sata 3 6GBPS. I have used the OkGear gold plated ones as well, with same results. – Richard Whitman Jul 25 '12 at 13:08
The common link seems to be the same motherboard in combination with high performance on the SATA bus. Could you post which motherboard (and which chipset) you are using? Maybe there are known problems with it. – Hennes Jul 25 '12 at 13:32

Your motherboard chipset is an Intel 3420, which despite being circa 2009, supports AHCI. I'm not very familiar with Linux, but the logs you posted seem to indicate you are using the legacy IDE or ATA mode.

In your BIOS configuration, change the drive controller mode to AHCI. You might have to reinstall your operating system after you do this.

share|improve this answer
I'd love to know why this was marked down. It's a SATA drive on a SATA controller and the log shows "configured for UDMA/133". – Jason Jul 31 '14 at 22:20
I agree with you. +1 from me. In any case a downvote ought to be explained. – MariusMatutiae Aug 1 '14 at 6:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.